How to run sweethome3d in Ubuntu 11.04

Asked by Henry Folorunsho on 2012-03-10

Hi Guys

Downloaded sweet home 3d, and try to lunch the software now it wont run. on 11.04

Henry

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu sweethome3d Edit question
Assignee:
No assignee Edit question
Solved by:
Henry Folorunsho
Solved:
2012-03-10
Last query:
2012-03-10
Last reply:
2012-03-10

This question was reopened

WHat happens when you try to run it?

Sweethome3d is a java software so need an installed java runtime

You can also run sweethome3d directly from the web from here...

http://www.sweethome3d.com/ click on the top page online link

To run the online version still need to have a jre plugin installed

Please open a terminal and type:

which java

to detect if java is installed and can be run into your system

then try to run sweethome3d from terminal just type

sweethome3d

Henry Folorunsho (henryxav) said : #3

Thanks

Nothing happens

Henry Folorunsho (henryxav) said : #4

Thanks

Nothing happens

seems you need to install java... please enable the partner repository from update-manager options then try from terminal:

sudo apt-get update
sudo apt-get --reinstall install sun-java6-jre

then retry...

Is java still packaged?

i really don't know ... but i'm afraid not we can wait for Henry feedback

Henry if you are in trouble installing java from partner repos try this:

http://www.webupd8.org/2011/03/install-java-in-ubuntu-1104-natty.html

Henry Folorunsho (henryxav) said : #9

thanks

solved by adding the PPA

i tried on Ubuntu 12.04 unstable here, i found it run with openjdk java and icedtea plugin...
so not with oracle/sun java installed...

sudo apt-get remove sun-java6-jre sun-java6-plugin
sudo apt-get autoremove

sudo apt-get --reinstall install openjdk-6-jre icedtea6-plugin icedtea-netx

Restarted firefox to try online release it works

Started sweethome3d coming from Ubuntu packages from terminal i get a warning

[warning] /usr/bin/sweethome3d: Unable to locate /usr/lib/jvm/java-6-sun/jre/lib/javaws.jar in /usr/share/java

but it seems works