sweethome3d can't find java runtime

Asked by Simon Oosthoek on 2011-05-03

In ubuntu 10.10 I was able to start sweethome3d (installed from a package in the repository (probably multiverse)).

Now, after upgrading to 11.04 I get this:

[warning] /usr/bin/sweethome3d: Unable to locate /usr/lib/jvm/java-6-sun/jre/lib/javaws.jar in /usr/share/java
Exception in thread "main" java.lang.NoClassDefFoundError: javax/jnlp/UnavailableServiceException
Caused by: java.lang.ClassNotFoundException: javax.jnlp.UnavailableServiceException
        at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
Could not find the main class: com.eteks.sweethome3d.SweetHome3D. Program will exit.

[1]+ Exit 1 sweethome3d

I tried re-installing the package of sweethome3d, but that didn't change the outcome when starting it.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu sweethome3d Edit question
Assignee:
No assignee Edit question
Solved by:
Simon Oosthoek
Solved:
2011-05-03
Last query:
2011-05-03
Last reply:
2011-05-03

Can you give the output of:

dpkg -l | grep java; java --version

Thanks

Simon Oosthoek (simon-margo) said : #2

$ dpkg -l | grep java; java --version
ii ca-certificates-java 20100412 Common CA certificates (JKS keystore)
ii java-common 0.40ubuntu1 Base of all Java packages
ii java-wrappers 0.1.16 wrappers for java executables
ii java3ds-fileloader 1.2+dfsg-1 Java3D 3DS File Loader
ii javahelp2 2.0.05.ds1-5 Java based help system
ii javascript-common 8 Base support for JavaScript library packages
ii libaccess-bridge-java 1.26.2-5 Java Access Bridge for GNOME
ii libaccess-bridge-java-jni 1.26.2-5 Java Access Bridge for GNOME (jni bindings)
ii libfreehep-export-java 2.1.1-1 FreeHEP Export and Save As Library
ii libfreehep-graphics2d-java 2.1.1-3 FreeHEP 2D Graphics Library
ii libfreehep-graphicsio-java 2.1.1-2 FreeHEP GraphicsIO Base Library
ii libfreehep-graphicsio-svg-java 2.1.1-3 FreeHEP Scalable Vector Graphics Driver
ii libfreehep-graphicsio-tests-java 2.1.1+dfsg1-3 FreeHEP GraphicsIO Test Library
ii libfreehep-io-java 2.0.2-3 FreeHEP I/O library
ii libfreehep-swing-java 2.0.3-3 FreeHEP swing extensions
ii libfreehep-util-java 2.0.2-4 FreeHEP utility library
ii libfreehep-xml-java 2.1.2+dfsg1-3 FreeHEP XML Library
ii libitext-java 2.1.7-2 Java Library to create and manipulate PDF on the fly
ii libjas-plotter-java 2.2.6+dfsg1-1 JAS(2) Plotter graphic library
ii libjava3d-java 1.5.2+dfsg-5 Java 3D API (java library)
ii libjava3d-jni 1.5.2+dfsg-5 Java3D API (java jni library)
ii libjaxp1.3-java 1.3.05-1ubuntu1 Java XML parser and transformer APIs (DOM, SAX, JAXP, TrAX)
ii libjdom1-java 1.1.1+dfsg-1 lightweight and fast library using XML
ii libopenide-util-java 6.7.1-2 OpenIde utility library
ii libsunflow-java 0.07.2.svn396+dfsg-7 rendering system for photo-realistic image synthesis
ii libtablelayout-java 20090826-1 Java layout manager for creating user interfaces fast and easy
ii libvecmath-java 1.5.2-2 javax.vecmath vector math package
ii libxerces2-java 2.9.1-4.1ubuntu2 Validating XML parser for Java with DOM level 3 support
ii plasma-scriptengine-javascript 4:4.6.2-0ubuntu1 the JavaScript script engine for Plasma
ii tzdata-java 2011g-0ubuntu0.11.04 time zone and daylight-saving time data for use by java runtimes
Unrecognized option: --version
Could not create the Java virtual machine.

I recommend you install sun java from the partner repo, it may help

Simon Oosthoek (simon-margo) said : #4

tnx, I must have had something like that before when it worked...

I had an older commented-out entry for lucid in my source.list, I wonder if that kept on working during maverick and not with the latest upgrade... Anyway, sweethome3d is working again!

Cheers

Simon

Simon Oosthoek (simon-margo) said : #5

Just to be more specific, I now have the following additional/uncommented lines in my /etc/apt/sources.list

deb http://archive.canonical.com/ubuntu natty partner
deb-src http://archive.canonical.com/ubuntu natty partner

It worked again after (re-?)installing sun-java6-jre