Getting Java to work on 12.10

Asked by Ivan

Hello, I am having trouble getting Java to workwith Firefox on Ubuntu 12.10 32bit system. It worked on 12.04 and LTZ 64bit. I am using a 32bit system now.

I've went to and tried installing the options they have. I also went to the Software center and nothing worked. I even opend up a terminal and tried from there installing 6 and 7. Both did not work. I don't understand what I'm doing wrong. It says that it was installed, but when I check on to see if I have it installed it says " No java has been detected."

I did a fresh install to start all over. I no longer have anything on my os right now just incase I did something wrong. Waiting for any type of advice

Question information

English Edit question
Ubuntu sun-java6 Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
marcobra (Marco Braida) (marcobra) said :
Revision history for this message
Ivan (rototrix) said :

So far everything has worked. When I tried to update java alternatives this is what happened. Not sure if this matters or not.

ivan@DeathCorps:~$ sudo update-java-alternatives -s java-7-oracle

update-java-alternatives: directory does not exist: /usr/lib/jvm/java-7-oracle

It says the directory doesn't exist???

Revision history for this message
Bhaveek Desai (bhaveekdesai) said :

Make sure you have the latest java installed, then follow the steps here:

Can you help with this problem?

Provide an answer of your own, or ask Ivan for more information if necessary.

To post a message you must log in.