Google chrome: tried to verify Java through java.com, but it says "Missing Plug-in" ...

Asked by Gnana Sekaran Nallathambi on 2011-11-13

Hi All,

I was checking through Ubuntu Software Center whether Java Run Time has been installed, but unable to find it out.

Tried to verify Java through java.com, but it says "Missing Plug-in" ... I'm using Google Chrome.

Please help me to install Java Run Time.

Thanks,
Gnana N.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu sun-java6 Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-13
Last reply:
2011-11-15

It's not in the repos anymore due to Oracle changing the license. If you can give the output of:

uname -a; lsb_release -a

Thanks

It's still in the repositories for every supported version of Ubuntu *except* Ubuntu 11.10, though you may want to install the version from Oracle's website anyway, as explained below.

If you're using Ubuntu 11.10, and you want to use proprietary Java from Oracle, you can get that at http://www.oracle.com/technetwork/java/index.html. You'll then have to manually ensure that it remains up to date. If you're using a previous release of Ubuntu but you want the latest release of Oracle's proprietary Java with the latest features and bug fixes, you should also go this route. Since this might include fixes for security vulnerabilities (which Ubuntu developers cannot fix because this is proprietary software), it is probably advisable to go this route **if you decide to use the proprietary version of Java at all**.

However, the free open source implementation of Java -- OpenJDK and the Icedtea browser plugin -- which is also official, is still provided in Ubuntu's official software sources, and there is no plan to ever stop providing that. To use the latest version of that, install the packages called openjdk-7-jre and icedtea-plugin.

If you're running a previous version of Ubuntu, then you can install sun-java6-jre and sun-java6-plugin (for Oracle's proprietary Java -- these are from the partner repository, but if you search for them in the Software Center you'll be given the opportunity to enable that repository automatically...alternatively you can enable it in the Software Sources and then install those packages however you want). But as explained above, if you're using Oracle's proprietary Java, you may want to obtain that from Oracle's website. Or, for the free open source Java, you can install openjdk-6-jre and icedtea-plugin (for Ubuntu 11.04), or openjdk6-jre and icedtea6-plugin (for previous supported Ubuntu releases).

If you need further assistance, then in your reply, please try to include the information that actionparsnip requested.

Can you help with this problem?

Provide an answer of your own, or ask Gnana Sekaran Nallathambi for more information if necessary.

To post a message you must log in.