How to remove symbolic links created in the plugins-map of firefox?

Asked by Niels Haver on 2011-07-30

I have downloaded and installed the jre-6u26-linux-i586.bin file according to instructions of the website

http://java.com/nl/download/help/linux_install.xml#selfextracting

Inside the plug-ins map of Firefox: cd /usr/lib/firefox/plugins/

I have created a symbolic link to the directory where Java is installed

ln -s /home/nielslnx/java/jre1.6.0_26/lib/i386/libnpjp2.so

I had to put sudo before it because the plug-ins map was owned by root. The symbolic link is not working but I am unable to open, edit or to remove it. Does anybody know how to make it work?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu sun-java6 Edit question
Assignee:
No assignee Edit question
Solved by:
Niels Haver
Solved:
2011-07-30
Last query:
2011-07-30
Last reply:
2011-07-30

You can remove the symbolic link with:

sudo rm /home/nielslnx/java/jre1.6.0_26/lib/i386/libnpjp2.so

http://java.com/nl/download/help/linux_install.xml#selfextracting is not, generally speaking, one of the better ways to install Java on Ubuntu. You may want to uninstall that, and install Java from officially supported Ubuntu packages. That should also fix the problem you're having getting the plugin to work in Firefox. See https://help.ubuntu.com/community/Java. Please note that:

(1) Both openjdk-6 and sun-java6 are officially supported, and they are both official Java from Oracle America (formerly Sun Microsystems).

(2) If you only have one Java implementation installed (for example, just openjdk-6/icedtea6 packages, or just sun-java6 packages), that will be the default, and you will not have to do anything with update-alternatives.

(3) If you choose to use sun-java6, you might consider using the version from the ppa:ferramroberto/java PPA, which might provide newer packages than Ubuntu's partner repository. See http://www.multimediaboom.com/how-to-install-java-in-ubuntu-11-04-natty-narwhal-ppa/.

Important correction: I had said that you could remove the symbolic link with:
sudo rm /home/nielslnx/java/jre1.6.0_26/lib/i386/libnpjp2.so

But that will remove the target. To remove the link itself, run:
sudo rm /usr/lib/firefox/plugins/libnpjp2.so

Niels Haver (nielshaver) said : #3

Thanks for the answer. I have noticed that I had already tried to put links to alternative java plugins in both Firefox and Firefox 5.0 . I have removed them all by using a terminal and entering in the directories by cd /usr/lib/firefox/plugins/ and by cd /usr/lib/firefox-5.0/plugins/ then I used the command sudo rm <link to remove>.so

Then I was able to create a working symbolic link inside Firefox but I got JAVA working when I created a symbolic link inside Firefox 5.0.