Java not working.

Asked by Patrick Case on 2011-03-02

I'm running Ubuntu 10.10 on an Apple Powerbook G4, and though I know that Java is already installed in my Applications folder and is enabled, it for some reason is not working in Firefox. At very least on the site adrive.com which I have some files backed up on that I would like to download. Anyone got any ideas as to what may be wrong?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu sun-java6 Edit question
Assignee:
No assignee Edit question
Last query:
2011-03-03
Last reply:
2011-03-03

Can you give the output of:

dpkg -l | grep java; uname -a; lsb_release -a

Thanks

Patrick Case (pufftones215) said : #2

when I pasted that into Terminal, here's what it spit back out at me

ii ca-certificates-java 20100412 Common CA certificates (JKS keystore)
ii java-common 0.38 Base of all Java packages
ii libaccess-bridge-java 1.26.2-5 Java Access Bridge for GNOME
ii libaccess-bridge-java-jni 1.26.2-5 Java Access Bridge for GNOME (jni bindings)
ii plasma-scriptengine-javascript 4:4.5.1-0ubuntu3.1 the JavaScript script engine for Plasma
ii tzdata-java 2010o-0ubuntu0.10.10 time zone and daylight-saving time data for use by java runtimes
Linux ubuntu 2.6.35-25-powerpc #44-Ubuntu Fri Jan 21 17:39:51 UTC 2011 ppc GNU/Linux
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.10
Release: 10.10
Codename: maverick

Enable the partner repo in the software centre and run:

sudo apt-get install sun-java6-jre sun-java6-plugin

Should do fine

Patrick Case (pufftones215) said : #4

Sorry, I'm kind of a noob, could you be more specific about enabling the partner repo?

In software centre -> Edit software sources and you can enable it in there

Patrick Case (pufftones215) said : #6

Ok, I did all that and here's what the output from the Terminal was

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package sun-java6-plugin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'sun-java6-plugin' has no installation candidate

Did you enable the repo?

ALso try running:

sudo apt-get update

first, then retry

Patrick Case (pufftones215) said : #8

The repo is the checkbox in the Other Software tab that says Canonical Partners correct? Cause I have that enabled. Tried doing the sudo apt-get update, that ran just fine, tried the install command again, go the same message.

Jason Odoom (jasonodoom) said : #9

Did you check to make sure the plugin was enabled through the preferences menu? Try this: sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

Can you help with this problem?

Provide an answer of your own, or ask Patrick Case for more information if necessary.

To post a message you must log in.