create /usr/java as administrator

Asked by James Seale on 2011-02-10

I am trying to install java sdk, I do not have permission to access ./usr

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu sun-java6 Edit question
Assignee:
No assignee Edit question
Solved by:
wojox
Solved:
2011-02-11
Last query:
2011-02-11
Last reply:
2011-02-11
James Seale (j-seale) said : #1

I have ubuntu 10.10 installed in a dual boot system on an intel machine

Please be more specific about exactly what you have done, including the exact error messages that you have received. In particular, if you downloaded any files yourself, specify where you downloaded them. If you're entering commands into the Terminal, please paste *all* the text from the Terminal (i.e. Edit > Select All; Edit > Copy) here.

Please also describe fully what it is that you are trying to accomplish. Do you just want to run Java programs, or do you also want to develop them? Since you have marked this question as relating to the package sun-java6, that suggests that you are attempting to install the official proprietary "freeware" version of Java, instead of the official free open source software version. Is that what you want?

Clarification: "...if you downloaded any files yourself, specify where you downloaded them FROM."

Best wojox (wojox) said : #4

To install (Sun) Java in Ubuntu 10.10 Maverick Meerkat you'll have to enable the Partner repository: open Ubuntu Software Center and go to Edit > Software Sources, then on the "Other Software" enable the Partner repository (it should be the first on the list; it looks like this: "http://archive.canonical.com/ubuntu maverick partner".).

Then, click "Close" and when asked, click "Reload" and finally install Sun Java6 in Ubuntu 10.10 by searching for it in Ubuntu Software Center.

James Seale (j-seale) said : #5

Thank you wojox, your instructions worked.

This help forum is so far better than others I have visited. Thank you all.