problem installing java runtime enviroment

Asked by Frederick Botha on 2010-11-18

Hi all, Im still very knew to how linux os work and not quite "with it" when it comes to computers in general. Ive been trying to install lime wire but It tells me I need Java Runtime Enviroment. I've been trying to install Java for the last 2 days and have had no luck so far. I went to this link: (http://www.ubuntugeek.com/how-to-install-java-runtime-environment-jre-in-ubuntu-904-jaunty.html) and followed instructions but this is what i got from the terminal:

frederick@frederick-laptop:~$ sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts
[sudo] password for frederick:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package sun-java6-jre is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package sun-java6-jre has no installation candidate
frederick@frederick-laptop:~$

Can any one help me, I'm not even sure I'm doing the right thing here?!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu sun-java6 Edit question
Assignee:
No assignee Edit question
Last query:
2010-11-18
Last reply:
2010-11-27
sikander3786 (sikander3786) said : #1

Which version of Ubuntu is this?

Go to Software Center > Edit > Software Sources > Other Software Tab and enable Canonical Partner Repositories.

sudo apt-get update && sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

GREG T. (ubuntuer) said : #2

 system = admin. = software sources =Other Software Tab and enable Canonical Partner Repositories
sudo apt-get update

sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

Frederick Botha (lushnumber) said : #3

I did all that and this is what I got:

frederick@frederick-laptop:~$ sudo apt-get update
[sudo] password for frederick:
Get: 1 http://security.ubuntu.com lucid-security Release.gpg [198B]
Get: 2 http://archive.canonical.com intrepid Release.gpg [198B]
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_GB
Ign http://archive.canonical.com/ubuntu/ intrepid/partner Translation-en_GB
Hit http://gb.archive.ubuntu.com lucid Release.gpg
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_GB
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_GB
Get: 3 http://archive.canonical.com intrepid Release [9,352B]
Get: 4 http://gb.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_GB [62.9kB]
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_GB
Get: 5 http://security.ubuntu.com lucid-security Release [38.5kB]
Get: 6 http://archive.canonical.com intrepid/partner Packages [3,362B]
Get: 7 http://archive.canonical.com intrepid/partner Sources [1,533B]
Get: 8 http://gb.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_GB [2,332B]
Get: 9 http://security.ubuntu.com lucid-security/main Packages [98.5kB]
Get: 10 http://gb.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_GB [33.9kB]
Get: 11 http://gb.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_GB [37.7kB]
Get: 12 http://gb.archive.ubuntu.com lucid-updates Release.gpg [198B]
Ign http://gb.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_GB
Ign http://gb.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_GB
Ign http://gb.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_GB
Ign http://gb.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_GB
Get: 13 http://security.ubuntu.com lucid-security/restricted Packages [14B]
Hit http://gb.archive.ubuntu.com lucid Release
Get: 14 http://gb.archive.ubuntu.com lucid-updates Release [44.7kB]
Get: 15 http://security.ubuntu.com lucid-security/main Sources [35.1kB]
Get: 16 http://security.ubuntu.com lucid-security/restricted Sources [14B]
Get: 17 http://security.ubuntu.com lucid-security/universe Packages [47.5kB]
Hit http://gb.archive.ubuntu.com lucid/main Packages
Hit http://gb.archive.ubuntu.com lucid/restricted Packages
Hit http://gb.archive.ubuntu.com lucid/main Sources
Hit http://gb.archive.ubuntu.com lucid/restricted Sources
Hit http://gb.archive.ubuntu.com lucid/universe Packages
Hit http://gb.archive.ubuntu.com lucid/universe Sources
Get: 18 http://security.ubuntu.com lucid-security/universe Sources [12.9kB]
Hit http://gb.archive.ubuntu.com lucid/multiverse Packages
Get: 19 http://security.ubuntu.com lucid-security/multiverse Packages [2,003B]
Get: 20 http://security.ubuntu.com lucid-security/multiverse Sources [660B]
Hit http://gb.archive.ubuntu.com lucid/multiverse Sources
Get: 21 http://gb.archive.ubuntu.com lucid-updates/main Packages [344kB]
Get: 22 http://gb.archive.ubuntu.com lucid-updates/restricted Packages [3,240B]
Get: 23 http://gb.archive.ubuntu.com lucid-updates/main Sources [134kB]
Get: 24 http://gb.archive.ubuntu.com lucid-updates/restricted Sources [1,443B]
Get: 25 http://gb.archive.ubuntu.com lucid-updates/universe Packages [148kB]
Get: 26 http://gb.archive.ubuntu.com lucid-updates/universe Sources [56.8kB]
Get: 27 http://gb.archive.ubuntu.com lucid-updates/multiverse Packages [7,373B]
Get: 28 http://gb.archive.ubuntu.com lucid-updates/multiverse Sources [3,669B]
Fetched 1,130kB in 35s (31.7kB/s)
Reading package lists... Done
frederick@frederick-laptop:~$ sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package sun-java6-jre is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package sun-java6-jre has no installation candidate
frederick@frederick-laptop:~$

Im not sure what version of Ubuntu I'm using, is there a way I can find out?

sikander3786 (sikander3786) said : #4

Your sources.list doesn't seem good.

Please post the output of

cat /etc/apt/sources.list

Or generate a new sources.list here and replace your existing with that.

http://repogen.simplylinux.ch/

Select your Country, Release, you need everything from Ubuntu Branches, Security and Updates from Ubuntu Updates and both Canonical Partner Repositories under Ubuntu Partner.

Good Luck!

Frederick Botha (lushnumber) said : #5

Hi, sorry it took so long to reply. been having problems with my internet connection. This is what I got from the imput:

frederick@frederick-laptop:~$ cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081029.5)]/ intrepid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://gb.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://gb.archive.ubuntu.com/ubuntu/ lucid restricted main multiverse universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://gb.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://gb.archive.ubuntu.com/ubuntu/ lucid-updates restricted main multiverse universe #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://gb.archive.ubuntu.com/ubuntu/ lucid universe
deb http://gb.archive.ubuntu.com/ubuntu/ lucid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://gb.archive.ubuntu.com/ubuntu/ lucid multiverse
deb http://gb.archive.ubuntu.com/ubuntu/ lucid-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://gb.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
# deb-src http://gb.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
deb http://archive.canonical.com/ubuntu intrepid partner
deb-src http://archive.canonical.com/ubuntu intrepid partner

deb http://security.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://security.ubuntu.com/ubuntu lucid-security restricted main multiverse universe #Added by software-properties
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb http://security.ubuntu.com/ubuntu lucid-security multiverse

Frederick Botha (lushnumber) said : #6

Hi, sorry it took so long to reply. been having problems with my internet connection. This is what I got from the imput:

frederick@frederick-laptop:~$ cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081029.5)]/ intrepid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://gb.archive.ubuntu.com/ubuntu/ lucid main restricted
deb-src http://gb.archive.ubuntu.com/ubuntu/ lucid restricted main multiverse universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://gb.archive.ubuntu.com/ubuntu/ lucid-updates main restricted
deb-src http://gb.archive.ubuntu.com/ubuntu/ lucid-updates restricted main multiverse universe #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://gb.archive.ubuntu.com/ubuntu/ lucid universe
deb http://gb.archive.ubuntu.com/ubuntu/ lucid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://gb.archive.ubuntu.com/ubuntu/ lucid multiverse
deb http://gb.archive.ubuntu.com/ubuntu/ lucid-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://gb.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
# deb-src http://gb.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
deb http://archive.canonical.com/ubuntu intrepid partner
deb-src http://archive.canonical.com/ubuntu intrepid partner

deb http://security.ubuntu.com/ubuntu lucid-security main restricted
deb-src http://security.ubuntu.com/ubuntu lucid-security restricted main multiverse universe #Added by software-properties
deb http://security.ubuntu.com/ubuntu lucid-security universe
deb http://security.ubuntu.com/ubuntu lucid-security multiverse

GREG T. (ubuntuer) said : #7

go to applications = software center = in the little window at the top right type in java . then when the list pops up see if it is installed , if not try to install .

Frederick Botha (lushnumber) said : #8

I went to software center and it says that java runtime is installed.
I said in my question that I was trying to install Lime wire and that it was telling me tht I needed java runtime enviroment... Im starting to think that Lime wire is just not working! Perhaps I should try looking for a different downloading program to use on my system.

GREG T. (ubuntuer) said : #10

limewire has court actions going on .

On 11/27/2010 03:44 PM, Frederick Botha wrote:
> Question #134533 on sun-java6 in ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/sun-java6/+question/134533
>
> Frederick Botha posted a new comment:
> I went to software center and it says that java runtime is installed.
> I said in my question that I was trying to install Lime wire and that it was telling me tht I needed java runtime enviroment... Im starting to think that Lime wire is just not working! Perhaps I should try looking for a different downloading program to use on my system.
>

Can you help with this problem?

Provide an answer of your own, or ask Frederick Botha for more information if necessary.

To post a message you must log in.