java install

Asked by Brad Ganson on 2010-09-18

how do I install java to play certain games

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu sun-java6 Edit question
Assignee:
No assignee Edit question
Solved by:
Brad Ganson
Solved:
2010-09-19
Last query:
2010-09-19
Last reply:
2010-09-18
Brad Ganson (bganson) said : #2

read all that but don't understand. can i just install something?

sun-java is in the partner repository

Step 1 - add partner repo from menu:
System → Administration → Software Sources
[ Other Software tab ] check "http://archive.canonical.com/ubuntu lucid partner"

Step 2 - update your apt database
press the Reload button after making above change or type "sudo apt-get update" using terminal

Step 3 - Open the Applications→Software-center
then you should find: sun-java6-jre and sun-java6-plugin (web plugin)
Or using terminal type:
sudo apt-get install sun-java6-jre sun-java6-plugin

If this still doesn't solve please read the already answered questions
 https://answers.launchpad.net/ubuntu/+source/sun-java6

Brad Ganson (bganson) said : #4

unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
error meesage after:
sudo apt-get update

please be sure to have only one package manager open in doubt the dumb way is to restart Ubuntu

Brad Ganson (bganson) said : #6

i don't have any open so so far as i know

So please reboot your ubuntu and retry

GREG T. (ubuntuer) said : #8

 easy way go to applications - software center , when it opens in the little window in the top right type in java and it will bring up sun java runtime , on the right click the arrow to install . watch for the the tab to pop up at the bottom that is the end user agreement . it will show up at around 50% of install .

GREG T. (ubuntuer) said : #9

 forgot it may be an install button .

Brad Ganson (bganson) said : #10

there is another problem. when i tried to uninstall the 2 java programs i found in the ubunut software center both said I needed to repair them before I could uninstall them. but don't have a clue how to go about repairing anything.

GREG T. (ubuntuer) said : #11

 i have no ideal how to repair these programs .

if it was mine i would reinstall the os then read more how to use it .

Brad Ganson (bganson) said : #12

administrator@ubuntu:~$ apt-get -f install
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

get this when i try repair

GREG T. (ubuntuer) said : #13

   sudo apt-get -f install

Brad Ganson (bganson) said : #14

sudo apt-get -f install
did it. thanks. even asked for iced tea

GREG T. (ubuntuer) said : #15

so is your problem solved ?

GREG T. (ubuntuer) said : #16

 sorry !click while scrolling . can you watch videos now ?

Brad Ganson (bganson) said : #17

es. the problem was didn't complete the java install. the dos window. couldn't figure out how to click OK. Finally used arrow keys to highlight. wasn't obvious.
playing backgammon online now with java