Ubuntu 9.04 Firefox 3.6 sun-java6

Asked by Carl Pham on 2010-07-27

Heavens, apparently Ubuntu has upgraded Firefox to 3.6 in Ubuntu 9.04, which
breaks the sun-java6 plugin. Is there any way around this?

The whole REASON I stayed at 9.04 is because the IcedTea plugin is pathetic, a joke, which doesn't work for all kinds of real-world enterprise Java. Is there a way to roll FF back to use the old sun-java6 plugin?

Actually, another reason I can't got to 10.04 is because gdb is broken under 10.04, and, gee, who can use a Linux system without a working debugger?

Anyone have a suggestion? Can I roll FF back somehow? Can I get the later sun-java6 plugin by hand, maybe?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu sun-java6 Edit question
Assignee:
No assignee Edit question
Solved by:
Carl Pham
Solved:
2010-07-27
Last query:
2010-07-27
Last reply:
2010-07-27
Carl Pham (carlpham8) said : #2

What a strange link. Did you not read the title of the question, which pointed out this is Ubuntu 9.04? What good is a link to how to install sun-java6 under 10.04?

I already HAVE sun-java6 installed -- but it's the one that came with 9.04, and it is quite different from the more modern version, that you can get in 10.04. The problem is that Ubuntu upgraded Firefox _in 9.04_ to the version (3.6) that required the new sun-java6, but they did NOT upgrade sun-java6 at the same time. So as of now, the FF and sun-java6 packages for 9.04 are inconsistent.

I know I can solve the whole FF/java problem by upgrading to 10.04, but as I said above, gcc is broken in 10.04 and that's a non-starter for anyone doing real programming, as I do.

Carl Pham (carlpham8) said : #3

Here is a link to the underlying issue:

http://www.java.com/en/download/faq/firefox_newplugin.xml

I've tried installing the sun-java6 packages from lucid by adding

deb http://archive.canonical.com/ lucid partner

to /etc/apt/sources.list, then doing

apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

No dice. Stuff installed, to be sure, and the *old* form of plugin (the oji file FF no longer supports) got updated, but the newer plugin didn't arrive.

Carl Pham (carlpham8) said : #4

OK, solved it. The problem is described here:

https://bugs.launchpad.net/ubuntu/+source/sun-java6/+bug/291135

In fact the new plugin does arrive when you install sun-java6 from the Lucid partner repository, as I described above. It's just stored somewhere new:

/usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so

The old style plugin is still in:

/usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so

So what you need to do is described in that bug report above. Roughly speaking, this:

cd /etc/alternatives
ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so firefox-javaplugin.so
ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so iceape-javaplugin.so
ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so iceweasel-javaplugin.so
ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so mozilla-javaplugin.so
ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so xulrunner-1.9-javaplugin.so
ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so xulrunner-javaplugin.so

The other links mentioned in that bug report (by Leo Milano) I didn't need, and it's possible different installations may have different links that need updating. As far as I know, the KEY aspects are this:

(1) Find out where libnpjp2.so lives.
(2) Update every java related link in /etc/alternatives to point from the old-style plugin (libjavaplugin_oji.so) to the new-style plugin (libnpjp2.so).
(3) I guess you'll want to make sure you've also got a link in /usr/lib/mozilla/plugins that's something like this:

/usr/lib/mozilla/plugins/libjavaplugin.so -> /etc/alternatives/mozilla-javaplugin.so

But this I'm less sure about. I'm not entirely sure how FF 3.6 finds its plugins.