java chatroom- no connection

Asked by Giovannino on 2009-03-14

I'm trying to connect to a java chatroom. using ubuntu/Firefox. I get a message "disconnected from server" on the login page. Before installing Ubuntu/Firefox I could get in. I can enter some java chatrooms, but others no. Is it a firewall problem?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu sun-java5 Edit question
Assignee:
No assignee Edit question
Solved by:
Giovannino
Solved:
2009-03-14
Last query:
2009-03-14
Last reply:
2009-03-14
peter (peter-neuweiler) said : #1

I'm not sure, if this helps. But make sure, that the following files are installed (all included in Synaptic). Once I couldn't login to a chatroom because I didn't have the last one of them.

- sun-java6-jre
- sun-java6-bin
- java-common
- sun-java6-plugin

Hope it helps.
Peter

Giovannino (johnsgarage) said : #2

Thank you for your suggestion. I searched add/remove applications, and it says that Synaptic is installed. I've also gone to the Adobe Flash web site and downloaded the flash player program, but when I install it, I get a message saying that I have a newer version already installed.

Giovannino (johnsgarage) said : #3

Oops, it's Java I need! I'll go to the Sun site this evening and see what happens.

Tom (tom6) said : #4

You can use Synaptic Package Manager to do all th hunting around for packages (applications/programs) for you and it can update all the packages you already have installed on your machine. Another excellent package manager is the "Add/Remove Application" that you can find on your Applications menu on the top taskbar. Unlike in Windows this can actually Add programs. Package managers are the best way to find and install packages in Linux. Let them do the work for you! lol. Try going up to the top taskbar and click on

System - Administration - Synaptic

it asks for your normal user password, not your SuperUser/Root one. Use either search tool to hunt for "java" and look through the list to find something relevant. Packages that you already have are marked with a green blob. Just right click and choose install to get others and then click "Apply" when your ready to have them installed. The "Search" button also searches through descriptions as well as titles so it allows you to be a bit vague. Note the "Mark all Updates" button btw

Err, i'm not sure if there's too much difference between chatrooms and "Instant Messenger" but Try going up to the top taskbar and click on

Applications - Internet - Pidgin

for an excellent "Instant Messenger" that can use multiple different protocols (Yahoo, msn etc) all at the same time. Sometimes it's difficult to remember which of your friends can't talk to each other easily because they are stuck to just one protocol at a time.

Good luck and regards from
Tom :)

Giovannino (johnsgarage) said : #5

I've checked, all of the java stuff listed are turned on. And no, it's not an instant message service. Would it help if I gave you guys a link to the chat room that's giving me problems? I appreciate all of the help and attention you are all giving me.

Giovannino (johnsgarage) said : #6

here's the link:
http://vshsvr2.chatblazer.net/vsh21/client.html

I just tried and got the message "Failed to connect to server" before I can even sign in.

Giovannino (johnsgarage) said : #7

here's the link:
http://vshsvr2.chatblazer.net/vsh21/client.html

I just tried and got the message "Failed to connect to server" before I can even sign in.

Giovannino (johnsgarage) said : #8

In MFirefox I went to:
Tools-Page Info-Permissions-clicked on to allow pop up windows and install extensions or themes. Now I can get in. Thanks again for all of your attention! Bill G. just took my loot and gave me the cold shoulder.

peter (peter-neuweiler) said : #9

I called your site and I got it. But I couldn't enter a Display name or a password. It's not possible.
Peter