How can I upgrade subversion to 1.7+

Asked by Dmitriy on 2015-10-28

Dear Sirs,

Due to technical reasons our new project requesting subversion 1.7 or newer. And due to the security reasons we can update packages from only. Unfortunately currently available in version of subversion is 1.6.17.

Can we expect subversion package upgrade to 1.7 or newer?

Sorry if the question is not correct. In that case, I'll be grateful for any advice to address our situation.

Dmitriy Ollyak

Question information

English Edit question
Ubuntu subversion Edit question
No assignee Edit question
Last query:
Last reply:

What is the output of:

lsb_release -a; uname -a


Dmitriy (ollyak) said : #2

Andrew, the output is

lsb_release -a:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.5 LTS
Release: 12.04
Codename: precise

uname -a
Linux 3.10.90-timeweb #1 SMP Wed Oct 7 12:28:33 MSK 2015 x86_64 x86_64 x86_64 GNU/Linux

Dmitriy (ollyak) said : #4

Thank you Andrew for info about PPA! Unfortunately I have no rights to upgrade packages anywhere except This is the limitation from my client.

Does anybody knows is there any chance that subversion will be upgraded from version 1.6.17 to 1.7 or newer on Kindly waiting for your answers.

Manfred Hampl (m-hampl) said : #5 is just some kind of inventory listing for the real Ubuntu repository servers ( and similar). So I do not really understand how you can be restricted to 'install/update only packages from'.

I do not think that there is any plan to upgrade subversion on Ubuntu precise to a higher version (except bug fixing of course).
You can try requesting that there is a higher version backported to precise, but I doubt that this will be successful.

I see the following options:
1. use a version from a PPA (as already recommended, apparently declined by you/your client)
2. upgrade your Ubuntu system from release 12.04 to 14.04 (with subversion 1.8.8)
3. try building the software from source (*)
4. try installing the official Ubuntu version for trusty on your precise system (*)
(*) Due to dependencies these actions might require that also some other packages are upgraded to higher versions (e.g. apr, db5.3 ...)

Dmitriy (ollyak) said : #6

Manfred, thank you for your detailed answer!

Can you help with this problem?

Provide an answer of your own, or ask Dmitriy for more information if necessary.

To post a message you must log in.