Ubuntu 20.04 autoinstall fails when I try to set the storage

Asked by Paul Lambert on 2021-04-28

I want to do an Ubuntu 20.04 autoinstall from a separate partition. The block structure:

At the begining the OS boots from an RHEL7 Core(not installed) loaded thru network from a central computer.

sda1 is created using:

===
  "mklabel gpt mkpart ESP fat16 1Mib 5GiB set 1 boot on".
===

On sda1 I have copied the data from the Ubuntu iso and added a nocloud folder that contains the files "user-data" and "meta-data".

===
The grub.cfg menu entry:

menuentry "Install Ubuntu Server" {
        set gfxpayload=keep
        linux /casper/vmlinuz autoinstall ds='nocloud;s=file://cdrom/nocloud/' ---
        initrd /casper/initrd
}
grub_platform
if [ "$grub_platform" = "efi" ]; then
menuentry 'Boot from next volume' {
        exit 1
}
menuentry 'UEFI Firmware Settings' {
        fwsetup
}
fi
===

Before rebooting I have:

===
sda
| -- sda1 vfat /cdrom (iso image copied) - bootable
===

I tried using the following configurations:

1. Using a simple, basic user-data configuration:

===
#cloud-config
autoinstall:
  version: 1
  identity:
    hostname: ubuntu-server2
    password: "$6$exDY1mhS4KUYCE/2$zmn9ToZwTKLhCw.b4/b.ZRTIZM30JZ4QrOQ2aOXJ8yk96xpcCof0kxKwuX1kqLG/ygbJ1f8wxED22bTL4F46P0"
    username: ubuntu
====

I get the error: "NoneType" object has no attribute "grub_device"

 2. Adding storage layout as "lvm" or "direct" exactlly as in documentation I get the same error.

3. Changing storage to:
===
storage:
    config:
    - grub_device: true
      id: disk-sda
      path: /dev/sda
      ptable: gpt
      type: disk
      wipe: superblock-recursive
===

I get the error: "No match"

 4. I also tried by adding dev/sda2 as root:

===
linux /casper/vmlinuz autoinstall root=/dev/sda2 ds='nocloud;s=file://cdrom/nocloud/' ---
===

Same errors as above.

5. tried to set the storage interactive for testing purpose:

===
interactive-sections:
    - storage
===

The autoinstall just freeze, no option to set storage available.

How can I fix this, and what are the rules to set storage in case of multiple storage devices ?

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu subiquity Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.