Ubuntu

wrong grub shown in start up manager after upgrade to 11.04

Asked by John Ling on 2011-07-25

I am running ubuntu along with XP. I upgraded from version 10.1 to 11.04 when asked by upgrade manager. I have tried to use startup manager to allow XP to start normally first, but it does not show the current boot menu, but the old one that was in use with 10.1. Could you please explain how to to get rid of the first grub boot menu, So that start up manager will operate normally.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu startupmanager Edit question
Assignee:
No assignee Edit question
Last query:
2011-07-25
Last reply:
2011-07-27
Joseph (joehms22) said : #1

I'm not entirely sure how this happened, as I believe the old grub should be used once you install the new OS unless it was installed on a new partition, anyhow, you might try running update-grub first, if that doesn't work, I would update the Grub configuration file manually.

To update the file manually, run:
gksudo gedit /boot/grub/grub.cfg

Don't worry about what it says about not editing the file.

In the file should be a setting that looks like this:
set default="0"

Change 0 to be the number of the entry that you want, so for instance, if your grub menu looks like this:

Ubuntu 10.04
Ubuntu 10.04 Recovery
Windows XP (Loader)
Damn Small Linux
Arch Linux

You would change the line to look like this:
set default="2"

Because XP is the second entry (starting from 0):

Hope it helps,
   Joe

delance (olivier-delance) said : #2

/boot/grub/grub.cfg will be rebuilt at next kernel delivery, and changes lost.
Check you use Grub2: "update-grub --version" should return 1.98 or 1.99
After see "How to make Windows showing in Grub2 menu" https://answers.launchpad.net/grub/+faq/1677

Can you help with this problem?

Provide an answer of your own, or ask John Ling for more information if necessary.

To post a message you must log in.