Can't remove phyton3.6 and leave only phyton3.8 - aftects to many other packages

Asked by linux.logwatch

According to
Phyton python3.6 has vulnerabilities, so I install phyton3.8:

  #python3 --version
Python 3.6.9
  #sudo apt update
  #sudo apt install python3.8
  #sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.6 1
  #sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.8 2
  #sudo update-alternatives --config python3
There are 2 choices for the alternative python3 (providing /usr/bin/python3).

  Selection Path Priority Status
* 0 /usr/bin/python3.6 1 auto mode
  1 /usr/bin/python3.6 1 manual mode
  2 /usr/bin/python3.8 2 manual mode

#python3 --version
Python 3.8.0

 But now I can't remove the 3.6 because it is marked as dependency by too many packages

is there a way to remove it without affecting the dependencies?

# apt-get remove python3.6-minimal python3.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  distro-info-data ldap-utils libbasicobjects0 libcollection4 libdhash1 libini-config5 libipa-hbac0 libnetplan0 libnl-route-3-200 libnspr4 libnss3 libpath-utils1
  libref-array1 libsmbclient libsss-certmap0 libsss-idmap0 libsss-nss-idmap0 libsss-sudo libxmlsec1 libxmlsec1-openssl libxslt1.1 python-sss zerofree
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  apparmor apt-listchanges byobu command-not-found dh-python fail2ban iotop landscape-client landscape-common language-selector-common libsss-simpleifp0 lsb-release networkd-dispatcher nplan open-vm-tools pastebinit plymouth-theme-ubuntu-text python3 python3-apport python3-apt python3-asn1crypto python3-attr
  python3-automat python3-certifi python3-cffi-backend python3-chardet python3-click python3-colorama python3-commandnotfound python3-configobj python3-constantly
  python3-cryptography python3-dbus python3-debconf python3-debian python3-distro-info python3-distupgrade python3-distutils python3-gdbm python3-gi python3-httplib2
  python3-hyperlink python3-idna python3-incremental python3-lib2to3 python3-minimal python3-netifaces python3-newt python3-openssl python3-pam python3-pkg-resources
  python3-problem-report python3-pyasn1 python3-pyasn1-modules python3-pycurl python3-pyinotify python3-requests python3-requests-unixsocket python3-serial
  python3-service-identity python3-six python3-software-properties python3-sss python3-systemd python3-twisted python3-twisted-bin python3-update-manager
  python3-urllib3 python3-yaml python3-zope.interface python3.6 python3.6-minimal software-properties-common ssh-import-id sssd sssd-ad sssd-ad-common sssd-common
  sssd-dbus sssd-ipa sssd-krb5 sssd-krb5-common sssd-ldap sssd-proxy sssd-tools ubuntu-minimal ubuntu-release-upgrader-core ufw unattended-upgrades
  update-manager-core update-notifier-common
0 upgraded, 0 newly installed, 92 to remove and 23 not upgraded.
After this operation, 60.3 MB disk space will be freed.
Do you want to continue? [Y/n]

Question information

English Edit question
Ubuntu sssd Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Best Manfred Hampl (m-hampl) said :

1. Which Ubuntu release are you running? I assume 18.04 bionic.

2. Yes, it is true. There are several dependencies on python3 version 3.6 that cannot be met by installing python3 version 3.8, e.g sssd:

sssd version 1.16.1-1ubuntu1.7 for bionic depends on python3-sss version 1.16.1-1ubuntu1.7
and python3-sss version 1.16.1-1ubuntu1.7 for bionic depends on (among others)
python3 (<< 3.7)
python3 (>= 3.6~)
If you uninstall python3 version 3.6.*, then the dependencies require uninstalling sssd.

3. The vulnerabilities listed in have been corrected in python3.6 version 3.6.9-1~18.04ubuntu1.3
If you upgrade your python3.6 package to the latest version (which is 3.6.9-1~18.04ubuntu1.4), you have a package that is no more vulnerable to the weaknesses listed in USN-4581-1 and even some additional vulnerabilities, see

Revision history for this message
linux.logwatch (linux.logwatch) said :

Thank you for the clarification Manfred