sshfs and iphone sync broken with last update

Asked by Rich

After the last update (around the beginning of march '11) sshfs and iphone syncing stopped working.
I am on a dell laptop running ubuntu 10.10 64bit

sshfs example:

richd@odin:~$ mkdir net
richd@odin:~$ sshfs richd@quadratus:/home/richd ./net/
richd@quadratus's password:
fusermount: failed to access mountpoint /home/richd/net: Permission denied

Doesn't matter what directory on the server i'm trying to mount, or what directory i am trying to mount to.
If i swap out /bin/fusermount with the one from fuse-utils_2.8.4-1ubuntu1.2_amd64.deb, sshfs works, but still no iphone sync.

Both of my iphones will show up on the desktop, work with Shotwell, and start Rhythmbox, but neither one will show up in Rhythmbox or Banshee. It all worked before the update.

So, I guess my real question is: how do i roll back the update?

Question information

English Edit question
Ubuntu sshfs-fuse Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Rolling back may cause issues but if you can find the old deb and install that it may work.

Did you log a bug too?

Revision history for this message
Rich (it-is-rich) said :

I'm not sure which .deb would have affected ipod/iphone sync. I have not logged a bug yet. I wasn't sure if this was a real bug or just some peculiarity with my machine.

It looks like the only real change in the updated fuse-utils was the fusermount binary, but that doesn't seem to help the iphone sync problem.


Revision history for this message
mycae (mycae) said :

Rich; you may want to look at your /var/log/dkpg log to see what changed from the date where it previously worked -- this will let you narrow down what packages have been altered on your system.

Unfortunately, the mirrors are only "live", so only the latest updates are necessarily kept. you may need to locate and manually resolve the dependency tree if you try to revert to an earlier version.

Revision history for this message
Rich (it-is-rich) said :

For the record:

Although my Ubuntu install was only a few weeks old, I wiped and reinstalled. After the install, I tested sshfs and iphone/ipod syncing, which both worked fine. I then allowed it do do all the updates (somewhere around 250 megs or so), after which, both sshfs and iphone/ipod syncing still worked fine.

I don't much like the fact that it took a reinstall to fix the problem (if i wanted to reinstall every time a problem occurred, I would use that other OS).

Anyway, I suppose I should tag this problem as solved, but I'm still annoyed. ;)


Revision history for this message
mycae (mycae) said :

well, unfortunately, unless you backed up your old copy, you nuked the only info we had -- which was the contents of that dpkg log... We might have been able to determine the cause from that; now we won't know unless you can reproduce the problem.

However, if is fixed for you, then that can only be a good thing. But in the future, if you want to make sure a problem is fixed more permanently, we need to be able to reproduce it.