Squid proxy transparent howto

Asked by Sunday Olutayo on 2009-01-20

I conduct a search for why my squid proxy "transparent" is not working, I found this;

" In package 2.6.1-3ubuntu1 , the transparent option in squid.conf is broken in Squid upstream version 2.6.RELEASE1. This has been fixed in 2.6.RELEASE2.

Recommend 2.6.RELEASE2 be added to edgy-backports."

Please how do I carry out the backporting?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu squid Edit question
Assignee:
No assignee Edit question
Solved by:
Sunday Olutayo
Solved:
2009-01-23
Last query:
2009-01-23
Last reply:
2009-01-22

This question was reopened

Tobias Jost (tjost) said : #1

Hello,

If you are still using Ubuntu Edgy Eft (released October 2006), I recommend you upgrading to a newer Version of Ubuntu Linux.

The Bug you mention should be fixed in Ubuntu since April last year.

Sunday Olutayo (solutayo) said : #2

Thanks for the support but I am using 8.04 LTS Hardy Heron

Andy Ruddock (andy-ruddock) said : #3

According to apt, squid is at version 2.6.18-1ubuntu3 for hardy.
If you have all hardy packages installed then the information you found does not apply to you and there must be some other reason that squid is not working for you.

Sunday Olutayo (solutayo) said : #4

Please this is the line:

http_port 3128 transparent

And is not working.

Sunday Olutayo (solutayo) said : #6

Thanks it work after adding this to iptables;

iptables -t nat -A PREROUTING -i eth1 -p tcp -j REDIRECT --to-port 3128

Thanks alot.

Sunday Olutayo (solutayo) said : #7

How I make the iptables setting to start at booting instead of having to type it everytime

Sunday Olutayo (solutayo) said : #8

How I do make the iptables setting to start at boot instead of having to type it everytime?

Thanks

Sunday Olutayo (solutayo) said : #9

I did it with this:

sudo iptables :

iptables -A INPUT -j LOG

Thanks

Sunday Olutayo (solutayo) said : #10

I did it with this:

sudo iptables -A INPUT -j LOG

Thanks