Unable to rip CD's into AAC format

Asked by Jeremy

Hello and many thanks in advance from this Linux noob.

I'm having a problem in SoundJuicer in that it won't seem to allow me to rip CD's into the AAC format. When I go to Edit -> Preferences the drop down menu with the formats it will allow does not include this format. I've then clicked on the "Edit Profiles" button which then has at the top of the list "CD Quality, AAC". Selecting that and clicking Edit brings up another window with the following information:

Profile name: CD Quality, AAC
GStreamer Pipeline: audio/x-raw-int,rate=44100,channels=2 ! faac ! ffmux_mp4
File extension: m4a

The "Active?" box is checked. To my uneducated eyes everything looks fine. A little help please? Thank you.

Question information

English Edit question
Ubuntu sound-juicer Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Jeremy (abolishthisciv) said :

Problem solved. It ends up I needed to install something else from gstreamer "bad" repositories.

Revision history for this message
Jörn Dreyer (j.dreyer) said :

I experienced this problem with Jaunty. The ffmpeg muxer seems to be borked somehow ... well ok I read every google hit I found and it turns out gstreamer devs discourage the use of ffmpeg en/de/cod/muxers. I switched to mp4mux from the qtmux encoder and it now works flawlessly :)

Revision history for this message
Jörn Dreyer (j.dreyer) said :

I forgot to paste my GStreamer Pipeline: "audio/x-raw-int,rate=44100,channels=2 ! faac profile=2 ! mp4muxer"
profile=2 selects the LC (Low Complexity) profile so the m4a will play nicely on your ipod. Use gconf-editor to change the pipeline under /system/gstreamer/0.10/audio/profiles/aac if your sound juicer has problems with that.

Revision history for this message
Jörn Dreyer (j.dreyer) said :

sry that is "audio/x-raw-int,rate=44100,channels=2 ! faac profile=2 ! mp4mux" ... no mp4muxER ... need sleep ... zZz ...