Ripped mp3s track info not correct in Amarok

Asked by VinylMatt on 2007-04-21

I can rip a cd to mp3 no problem, sound-juicer shows the album name and artist and each track is saved with the correct track name.
Now if I go to play the ripped cd in Amarok all the track info is missing.
Anyone know how to correct this?
Thanks in advance,
Matt.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu sound-juicer Edit question
Assignee:
No assignee Edit question
Solved by:
VinylMatt
Solved:
2007-04-22
Last query:
2007-04-22
Last reply:
2007-04-21
Massimo Forti (slackwarelife) said : #1

If you open Rhythmbox you be able to see the meta data info ???

VinylMatt (mcremore) said : #2

No - doesn't show in RhythmBox either. It comes up as Unknown album. The titles are right but the artist and album name are all unknown.

Massimo Forti (slackwarelife) said : #3

We can do a little experiment:
open Rhythmbox, click with right button on a .mp3 file, you choose "property", change the meta data. Than close Rhythmbox and open amarok. The meta data are ok ???

VinylMatt (mcremore) said : #4

Yes - if I do that then both Amarok and RhythmBox are OK.

Best VinylMatt (mcremore) said : #5

I've just had a look at the actual mp3 files properties in the file browser and on the Audio tab for the tracks sound juicer has ripped all the info is set to unknown.
Just tried the same cd in Ogg and the meta data is correct.
This was my old mp3 settings
audio/x-raw-int,rate=44100,channels=2 ! lame name=enc
I've just changed it to:
audio/x-raw-int,rate=44100,channels=2 ! lame name=enc preset=1001 ! xingmux ! id3v2mux

I'm not sure what the extra bits do but it seems to have fixed the problem.
(Is there anywhere which explains what these settings do?)
Thanks slackwarelife for your help on this,
Cheers,
Matt.