moving files

Asked by Kevin on 2008-06-20

I have Ubuntu 8.04
and I have a 60 GB portable hard drive.
That I have have been trying to move a 4.3 GB file on it.
But once it has moved 4.0 GB on it stops and says

Error while copying
“openSUSE-11.0-DVD-i386.ios”.
There was an error copying the file into /media/disk

Show more details
Error writing to file: File too large

So how do I let it save the bigger files???

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu sound-juicer Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2008-06-21
Last query:
2008-06-21
Last reply:
2008-06-21

If your 60gb portable hard disk is with a with Fat32 filesystem you cannot write file bigger than 4giga

The maximum possible size for a file on a FAT32 volume is 4 GB minus 1 "null" byte (232−1 bytes).

http://en.wikipedia.org/wiki/File_Allocation_Table

Try to format your 60gb with NTFS or EXT3 filesystem

Hope this helps

Kevin (kevinrs91) said : #2

I format my 60 GB portable hard drive to NTFS.
But now it says

Cannot mount volume.
Unable to mount the volume.

Details
$LogFile indicates unclean shutdown (0, 1) Failed to mount '/
dev/sdb1':Operation not suppored Mount is denied because
NTFS is marked to be in use. Choose one action: choice 1: If
you have Windows then disconnect the external devices
by clicking on the 'Safely Remove Hardware' icon in the
Windows taskbar then shotdown Windows cleanly.
Choice: If you don't have Windows then you can use the
'force' option for your own responsibility. For example
type on the command line: mount -t ntfs-3g /dev/
sdb1 /media/disk -o force or add the option to the relevant
row in the /ect/fstab file: /dev/sbd1/media/disk ntfs-3g
force 0 0

and none of the choice work
I must be doing something wrong

If you can mount your usb NTFS device under win and please remove it before shutdown windows and retry.

Hope this helps

Kevin (kevinrs91) said : #4

Thanks

Kevin (kevinrs91) said : #5

Thanks marcobra, that solved my question.

John Ward (automail) said : #6

Another thing to do is install "ntfsprogs" in Ubuntu [ Terminal: sudo apt-get install ntfsprogs ]. One of the programs that comes with it is "ntfsfix". You would run it as such: " sudo ntfsfix /dev/sd*# " where * is your disk id and # is your partition number i.e. "sdb1".

This method will prevent you from having to go into Windows to reset the disconnect parameters, i.e. plugging it in and doing a "Safely Remove Hardware".