Ubuntu 16.04 does not boot

Asked by Sushant Potdar on 2020-03-24

I have a Dell Precision with a pre-installed Ubuntu 16.04 OS and very close to a year old. There were some software updates that were installed and since then the OS is not booting. I tried some of the online solutions, like adding nomodeset and nouveau.modeset=0 at the end of the linux line in GRUB, or trying to run the Linux recovery mode under the "Advanced options for Linux" in GRUB. But none of these worked and the screen is just blank for some time. Can someone help me with this? Thank you very much.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu software-center Edit question
Assignee:
No assignee Edit question
Solved by:
Sushant Potdar
Solved:
2020-03-25
Last query:
2020-03-25
Last reply:
2020-03-25
Sushant Potdar (sdpotdar) said : #1

Correction: I have 18.04 and not 16.04

If you boot an older kernel is it OK?

Sushant Potdar (sdpotdar) said : #3

Yes, when I launched an older recovery kernel, it took me to the GRUB recovery menu (filesystem state: read-only)

Sounds like you need to fsck your partition. If you boot to the Ubuntu install media you can do the check there

Sushant Potdar (sdpotdar) said : #5

So I figured out one more thing, which might be helpful in solving my issue. My system boots normally and also reboots normally when the charger is connected. However, if I try to reboot it without connecting the charger, it freezes. After that, I have to connect the charger again to start it.

Do you have the latest BIOS?

Sushant Potdar (sdpotdar) said : #7

How do I check that?

Sushant Potdar (sdpotdar) said : #8

I have BIOS 1.11.1 version. I think this is the latest version.

I suggest you report a bug. Upgrading to Focal (Ubuntu 20.04) may help. Focal is LTS and upgrading from Bionic to Focal on one jump is supported

Sushant Potdar (sdpotdar) said : #10

I think I was able to solve this issue. I referred to the DELL forum and found that I had to change some code in the grub file. The codes I used after recovery booting it were as follows:

sudo gedit /etc/default/grub

In the file that opens, I went to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" line and added "dis_ucode_ldr" at the end. The line looks like this after the edit:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash dis_ucode_ldr"

I saved it and back on terminal, I ran:

sudo update-grub

Then I restarted my machine and I was able to boot Ubuntu without power supply.

Great find and awesome share! Hopefully this will help others.