error broken count>0 unmet dependencies

Asked by jiacheng yuan on 2019-01-26

The error message was: 'Error Broken Count > 0' This usually means that your packages have unmet dependencies.
I took a look at some previous similar problems.
Here are some output of diagnostic commands:

uname -a
lsb_release -crid
sudo dpkg --audit
sudo dpkg --configure -a

jc@jc-XPS-15:~$ uname -a
Linux jc-XPS-15 4.15.0-43-generic #46~16.04.1-Ubuntu SMP Fri Dec 7 13:31:08 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
jc@jc-XPS-15:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 16.04.5 LTS
Release: 16.04
Codename: xenial
jc@jc-XPS-15:~$ sudo dpkg --audit
The following packages are in a mess due to serious problems during
installation. They must be reinstalled for them (and any packages
that depend on them) to function properly:
 unattended-upgrades automatic installation of security upgrades

The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
 apt-transport-https https download transport for APT
 apt-utils package management related utility programs
 ghostscript interpreter for the PostScript language and for PDF
 ghostscript-x interpreter for the PostScript language and for PDF - X11
 krb5-locales Internationalization support for MIT Kerberos
 krb5-multidev Development files for MIT Kerberos without Heimdal confli
 libapt-inst2.0:amd64 deb package format runtime library
 libarchive13:amd64 Multi-format archive and compression library (shared libr
 libcaca0:amd64 colour ASCII art library
 libgs9:amd64 interpreter for the PostScript language and for PDF - Lib
 libgs9-common interpreter for the PostScript language and for PDF - com
 libgssapi-krb5-2:amd64 MIT Kerberos runtime libraries - krb5 GSS-API Mechanism
 libgssrpc4:amd64 MIT Kerberos runtime libraries - GSS enabled ONCRPC
 libk5crypto3:amd64 MIT Kerberos runtime libraries - Crypto Library
 libkadm5clnt-mit9:amd64 MIT Kerberos runtime libraries - Administration Clients
 libkadm5srv-mit9:amd64 MIT Kerberos runtime libraries - KDC and Admin Server
 libkdb5-8:amd64 MIT Kerberos runtime libraries - Kerberos database
 libkrb5-3:amd64 MIT Kerberos runtime libraries
 libkrb5support0:amd64 MIT Kerberos runtime libraries - Support library
 libmysqlclient-dev MySQL database development files
 libmysqlclient20:amd64 MySQL database client library
 libpolkit-agent-1-0:amd64 PolicyKit Authentication Agent API
 libpolkit-backend-1-0:amd64 PolicyKit backend API
 libpolkit-gobject-1-0:amd64 PolicyKit Authorization API
 libpoppler-glib8:amd64 PDF rendering library (GLib-based shared library)
 libpoppler58:amd64 PDF rendering library
 libtiff5:amd64 Tag Image File Format (TIFF) library
 libtiff5-dev:amd64 Tag Image File Format library (TIFF), development files
 libtiffxx5:amd64 Tag Image File Format (TIFF) library -- C++ interface
 mysql-common MySQL database common files, e.g. /etc/mysql/my.cnf
 policykit-1 framework for managing administrative policies and privil
 poppler-utils PDF utilities (based on Poppler)
 thunderbird Email, RSS and newsgroup client with integrated spam filt
 thunderbird-gnome-support Email, RSS and newsgroup client - GNOME support
 thunderbird-locale-en English language pack for Thunderbird
 thunderbird-locale-en-us Transitional English language pack for Thunderbird

The following packages have been triggered, but the trigger processing
has not yet been done. Trigger processing can be requested using
dselect or dpkg --configure --pending (or dpkg --triggers-only):
 bamfdaemon Window matching library - daemon
 dbus simple interprocess messaging system (daemon and utilitie
 desktop-file-utils Utilities for .desktop files
 gnome-menus GNOME implementation of the freedesktop menu specificatio
 libc-bin GNU C Library: Binaries
 man-db on-line manual pager
 mime-support MIME files 'mime.types' & 'mailcap', and support programs

jc@jc-XPS-15:~$ sudo dpkg --configure -a
Setting up libgs9-common (9.26~dfsg+0-0ubuntu0.16.04.4) ...
Setting up libapt-inst2.0:amd64 (1.2.29ubuntu0.1) ...
Setting up apt-transport-https (1.2.29ubuntu0.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.2) ...
Setting up libarchive13:amd64 (3.1.2-11ubuntu0.16.04.5) ...
Setting up apt-utils (1.2.29ubuntu0.1) ...
Setting up mysql-common (5.7.25-0ubuntu0.16.04.2) ...
Setting up libtiff5:amd64 (4.0.6-1ubuntu0.5) ...
Setting up libkrb5support0:amd64 (1.13.2+dfsg-5ubuntu2.1) ...
Setting up thunderbird (1:60.4.0+build2-0ubuntu0.16.04.1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Setting up krb5-locales (1.13.2+dfsg-5ubuntu2.1) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Setting up thunderbird-gnome-support (1:60.4.0+build2-0ubuntu0.16.04.1) ...
dpkg: error processing package unattended-upgrades (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
Setting up libtiffxx5:amd64 (4.0.6-1ubuntu0.5) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up libmysqlclient20:amd64 (5.7.25-0ubuntu0.16.04.2) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for dbus (1.10.6-1ubuntu3.3) ...
Setting up libpoppler58:amd64 (0.41.0-0ubuntu1.11) ...
Setting up libcaca0:amd64 (0.99.beta19-2ubuntu0.16.04.1) ...
Setting up libgs9:amd64 (9.26~dfsg+0-0ubuntu0.16.04.4) ...
Setting up libpolkit-gobject-1-0:amd64 (0.105-14.1ubuntu0.4) ...
Setting up libpoppler-glib8:amd64 (0.41.0-0ubuntu1.11) ...
Setting up libk5crypto3:amd64 (1.13.2+dfsg-5ubuntu2.1) ...
Setting up poppler-utils (0.41.0-0ubuntu1.11) ...
Setting up libmysqlclient-dev (5.7.25-0ubuntu0.16.04.2) ...
Setting up libpolkit-agent-1-0:amd64 (0.105-14.1ubuntu0.4) ...
Setting up libtiff5-dev:amd64 (4.0.6-1ubuntu0.5) ...
Setting up ghostscript (9.26~dfsg+0-0ubuntu0.16.04.4) ...
Setting up thunderbird-locale-en (1:60.4.0+build2-0ubuntu0.16.04.1) ...
Setting up thunderbird-locale-en-us (1:60.4.0+build2-0ubuntu0.16.04.1) ...
Setting up libpolkit-backend-1-0:amd64 (0.105-14.1ubuntu0.4) ...
Setting up libkrb5-3:amd64 (1.13.2+dfsg-5ubuntu2.1) ...
Setting up ghostscript-x (9.26~dfsg+0-0ubuntu0.16.04.4) ...
Setting up policykit-1 (0.105-14.1ubuntu0.4) ...
Setting up libgssapi-krb5-2:amd64 (1.13.2+dfsg-5ubuntu2.1) ...
Setting up libgssrpc4:amd64 (1.13.2+dfsg-5ubuntu2.1) ...
Setting up libkadm5clnt-mit9:amd64 (1.13.2+dfsg-5ubuntu2.1) ...
Setting up libkdb5-8:amd64 (1.13.2+dfsg-5ubuntu2.1) ...
Setting up libkadm5srv-mit9:amd64 (1.13.2+dfsg-5ubuntu2.1) ...
Setting up krb5-multidev (1.13.2+dfsg-5ubuntu2.1) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Errors were encountered while processing:
 unattended-upgrades

Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu software-center Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-01-26
Last query:
2019-01-26
Last reply:
2019-01-26
Best Manfred Hampl (m-hampl) said : #1

Try

sudo apt install --reinstall unattended-upgrades -f

jiacheng yuan (kracon7) said : #2

Hi Manfred,
Thanks for reply!
I reinstalled the package and now there is no output when I ran "sudo dpkg --audit" and "sudo dpkg --configure -a"
Does it mean my problem has been solved?

Manfred Hampl (m-hampl) said : #3

Yes, this command probably has solved the problem.

To verify, run the command

sudo apt update
sudo apt dist-upgrade

and check for warnings and error messages.

jiacheng yuan (kracon7) said : #4

There was no warnings and error messages when I ran those command. Thank you so much!!

jiacheng yuan (kracon7) said : #5

Thanks Manfred Hampl, that solved my question.