Can't download from Software Center and other

Asked by Adam on 2015-01-09

I'm trying to download Steam on my chromebook that is also running Ubuntu. I successfully downloaded the file for steam, but I can't get it to run. When I open it in the software center, the only response I get when I click install is it briefly says installing then goes back to the previous text and nothing actually installs. This is actually what happens when I try to download anything from the Software Center, for that matter. Am I doing something wrong?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu software-center Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2015-01-09
Last query:
2015-01-09
Last reply:
2015-01-09
Manfred Hampl (m-hampl) said : #2

Please provide the output of the following terminal commands:

uname -a
lsb_release -crid
sudo apt-get update
dpkg -l | grep steam

Adam (adamussher) said : #3

(precise)adamussher@localhost:~$ uname -a
Linux localhost 3.8.11 #1 SMP Wed Dec 10 14:41:54 PST 2014 armv7l armv7l armv7l GNU/Linux
(precise)adamussher@localhost:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 12.04.5 LTS
Release: 12.04
Codename: precise
(precise)adamussher@localhost:~$ sudo apt-get update
[sudo] password for adamussher:
Hit http://ports.ubuntu.com precise Release.gpg
Hit http://ports.ubuntu.com precise-updates Release.gpg
Hit http://ports.ubuntu.com precise-security Release.gpg
Hit http://ports.ubuntu.com precise Release
Hit http://ports.ubuntu.com precise-updates Release
Hit http://ports.ubuntu.com precise-security Release
Hit http://ports.ubuntu.com precise/main Sources
Hit http://ports.ubuntu.com precise/restricted Sources
Hit http://ports.ubuntu.com precise/universe Sources
Hit http://ports.ubuntu.com precise/multiverse Sources
Hit http://ports.ubuntu.com precise/main armhf Packages
Hit http://ports.ubuntu.com precise/restricted armhf Packages
Hit http://ports.ubuntu.com precise/universe armhf Packages
Hit http://ports.ubuntu.com precise/multiverse armhf Packages
Hit http://ports.ubuntu.com precise/main TranslationIndex
Hit http://ports.ubuntu.com precise/multiverse TranslationIndex
Hit http://ports.ubuntu.com precise/restricted TranslationIndex
Hit http://ports.ubuntu.com precise/universe TranslationIndex
Hit http://ports.ubuntu.com precise-updates/main Sources
Hit http://ports.ubuntu.com precise-updates/restricted Sources
Hit http://ports.ubuntu.com precise-updates/universe Sources
Hit http://ports.ubuntu.com precise-updates/multiverse Sources
Hit http://ports.ubuntu.com precise-updates/main armhf Packages
Hit http://ports.ubuntu.com precise-updates/restricted armhf Packages
Hit http://ports.ubuntu.com precise-updates/universe armhf Packages
Hit http://ports.ubuntu.com precise-updates/multiverse armhf Packages
Hit http://ports.ubuntu.com precise-updates/main TranslationIndex
Hit http://ports.ubuntu.com precise-updates/multiverse TranslationIndex
Hit http://ports.ubuntu.com precise-updates/restricted TranslationIndex
Hit http://ports.ubuntu.com precise-updates/universe TranslationIndex
Hit http://ports.ubuntu.com precise-security/main Sources
Hit http://ports.ubuntu.com precise-security/restricted Sources
Hit http://ports.ubuntu.com precise-security/universe Sources
Hit http://ports.ubuntu.com precise-security/multiverse Sources
Hit http://ports.ubuntu.com precise-security/main armhf Packages
Hit http://ports.ubuntu.com precise-security/restricted armhf Packages
Hit http://ports.ubuntu.com precise-security/universe armhf Packages
Hit http://ports.ubuntu.com precise-security/multiverse armhf Packages
Hit http://ports.ubuntu.com precise-security/main TranslationIndex
Hit http://ports.ubuntu.com precise-security/multiverse TranslationIndex
Hit http://ports.ubuntu.com precise-security/restricted TranslationIndex
Hit http://ports.ubuntu.com precise-security/universe TranslationIndex
Hit http://ports.ubuntu.com precise/main Translation-en
Hit http://ports.ubuntu.com precise/multiverse Translation-en
Hit http://ports.ubuntu.com precise/restricted Translation-en
Hit http://ports.ubuntu.com precise/universe Translation-en
Hit http://ports.ubuntu.com precise-updates/main Translation-en
Hit http://ports.ubuntu.com precise-updates/multiverse Translation-en
Hit http://ports.ubuntu.com precise-updates/restricted Translation-en
Hit http://ports.ubuntu.com precise-updates/universe Translation-en
Hit http://ports.ubuntu.com precise-security/main Translation-en
Hit http://ports.ubuntu.com precise-security/multiverse Translation-en
Hit http://ports.ubuntu.com precise-security/restricted Translation-en
Hit http://ports.ubuntu.com precise-security/universe Translation-en
Reading package lists... Done
(precise)adamussher@localhost:~$ dpkg -l | grep steam
(precise)adamussher@localhost:~$

ok, and the output of:

sudo apt-get upgrade

Thanks

Adam (adamussher) said : #5

(precise)adamussher@localhost:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

@Adam: The Steam client does not run on ARM CPU's.

Read this:

http://www.reddit.com/r/chromeos/comments/2h8vmu/samsung_arm_based_chromebook_with_steam/

Your Terminal output shows this:

(precise)adamussher@localhost:~$ uname -a
Linux localhost 3.8.11 #1 SMP Wed Dec 10 14:41:54 PST 2014 armv7l armv7l armv7l GNU/Linux

Adam (adamussher) said : #7

So it looks like I'm stuck for a while. Thanks for your help!

Adam (adamussher) said : #8

Thanks Mark Rijckenberg, that solved my question.