Unable to install new packages 14.04

Asked by max on 2014-09-23

I've looked at other similar threads but I feel uncomfortable purging things that may or may not have to do with my issue so here is a new thread. When I try running my software update it ends up saying "package operation failed" every time. Let me know what I should enter into terminal and copy/paste here. Thanks so much for the help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu software-center Edit question
Assignee:
No assignee Edit question
Solved by:
max
Solved:
2014-10-01
Last query:
2014-10-01
Last reply:
2014-09-30

What is the output of:

sudo apt-get update; df -h

Thanks

max (maxgolding1) said : #2

Ign http://dl.google.com stable InRelease
Get:1 http://dl.google.com stable Release.gpg [198 B]
Get:2 http://dl.google.com stable Release [1,347 B]
Ign http://security.ubuntu.com trusty-security InRelease
Ign http://us.archive.ubuntu.com trusty InRelease
Ign http://archive.canonical.com trusty InRelease
Get:3 http://dl.google.com stable/main i386 Packages [1,193 B]
Ign http://ppa.launchpad.net trusty InRelease
Ign http://us.archive.ubuntu.com trusty-updates InRelease
Get:4 http://security.ubuntu.com trusty-security Release.gpg [933 B]
Ign http://extras.ubuntu.com trusty InRelease
Hit http://archive.canonical.com trusty Release.gpg
Ign http://us.archive.ubuntu.com trusty-backports InRelease
Hit http://ppa.launchpad.net trusty Release.gpg
Hit http://us.archive.ubuntu.com trusty Release.gpg
Hit http://archive.getdeb.net trusty-getdeb InRelease
Get:5 http://security.ubuntu.com trusty-security Release [59.7 kB]
Hit http://extras.ubuntu.com trusty Release.gpg
Hit http://archive.canonical.com trusty Release
Hit http://ppa.launchpad.net trusty Release
Get:6 http://us.archive.ubuntu.com trusty-updates Release.gpg [933 B]
Hit http://us.archive.ubuntu.com trusty-backports Release.gpg
Hit http://extras.ubuntu.com trusty Release
Hit http://archive.canonical.com trusty/partner i386 Packages
Hit http://ppa.launchpad.net trusty/main i386 Packages
Hit http://us.archive.ubuntu.com trusty Release
Ign http://dl.google.com stable/main Translation-en_US
Get:7 http://us.archive.ubuntu.com trusty-updates Release [59.7 kB]
Hit http://archive.getdeb.net trusty-getdeb/apps i386 Packages
Ign http://dl.google.com stable/main Translation-en
Hit http://extras.ubuntu.com trusty/main Sources
Hit http://archive.canonical.com trusty/partner Translation-en
Hit http://ppa.launchpad.net trusty/main Translation-en
Hit http://archive.getdeb.net trusty-getdeb/games i386 Packages
Hit http://extras.ubuntu.com trusty/main i386 Packages
Get:8 http://security.ubuntu.com trusty-security/main Sources [44.9 kB]
Hit http://us.archive.ubuntu.com trusty-backports Release
Hit http://us.archive.ubuntu.com trusty/main Sources
Hit http://us.archive.ubuntu.com trusty/restricted Sources
Get:9 http://security.ubuntu.com trusty-security/restricted Sources [14 B]
Hit http://us.archive.ubuntu.com trusty/universe Sources
Hit http://us.archive.ubuntu.com trusty/multiverse Sources
Get:10 http://security.ubuntu.com trusty-security/universe Sources [10.8 kB]
Hit http://us.archive.ubuntu.com trusty/main i386 Packages
Hit http://us.archive.ubuntu.com trusty/restricted i386 Packages
Get:11 http://security.ubuntu.com trusty-security/multiverse Sources [700 B]
Hit http://us.archive.ubuntu.com trusty/universe i386 Packages
Hit http://us.archive.ubuntu.com trusty/multiverse i386 Packages
Get:12 http://security.ubuntu.com trusty-security/main i386 Packages [136 kB]
Hit http://us.archive.ubuntu.com trusty/main Translation-en
Hit http://us.archive.ubuntu.com trusty/multiverse Translation-en
Ign http://extras.ubuntu.com trusty/main Translation-en_US
Hit http://us.archive.ubuntu.com trusty/restricted Translation-en
Ign http://extras.ubuntu.com trusty/main Translation-en
Get:13 http://security.ubuntu.com trusty-security/restricted i386 Packages [14 B]
Hit http://us.archive.ubuntu.com trusty/universe Translation-en
Get:14 http://us.archive.ubuntu.com trusty-updates/main Sources [120 kB]
Get:15 http://security.ubuntu.com trusty-security/universe i386 Packages [48.4 kB]
Get:16 http://security.ubuntu.com trusty-security/multiverse i386 Packages [1,398 B]
Get:17 http://us.archive.ubuntu.com trusty-updates/restricted Sources [1,408 B]
Get:18 http://us.archive.ubuntu.com trusty-updates/universe Sources [85.2 kB]
Hit http://security.ubuntu.com trusty-security/main Translation-en
Hit http://security.ubuntu.com trusty-security/multiverse Translation-en
Get:19 http://us.archive.ubuntu.com trusty-updates/multiverse Sources [3,527 B]
Get:20 http://us.archive.ubuntu.com trusty-updates/main i386 Packages [317 kB]
Hit http://security.ubuntu.com trusty-security/restricted Translation-en
Hit http://security.ubuntu.com trusty-security/universe Translation-en
Ign http://archive.getdeb.net trusty-getdeb/apps Translation-en_US
Get:21 http://us.archive.ubuntu.com trusty-updates/restricted i386 Packages [5,820 B]
Ign http://archive.getdeb.net trusty-getdeb/apps Translation-en
Get:22 http://us.archive.ubuntu.com trusty-updates/universe i386 Packages [205 kB]
Ign http://archive.getdeb.net trusty-getdeb/games Translation-en_US
Get:23 http://us.archive.ubuntu.com trusty-updates/multiverse i386 Packages [9,545 B]
Hit http://us.archive.ubuntu.com trusty-updates/main Translation-en
Hit http://us.archive.ubuntu.com trusty-updates/multiverse Translation-en
Ign http://archive.getdeb.net trusty-getdeb/games Translation-en
Hit http://us.archive.ubuntu.com trusty-updates/restricted Translation-en
Get:24 http://us.archive.ubuntu.com trusty-updates/universe Translation-en [103 kB]
Hit http://us.archive.ubuntu.com trusty-backports/main Sources
Hit http://us.archive.ubuntu.com trusty-backports/restricted Sources
Hit http://us.archive.ubuntu.com trusty-backports/universe Sources
Hit http://us.archive.ubuntu.com trusty-backports/multiverse Sources
Hit http://us.archive.ubuntu.com trusty-backports/main i386 Packages
Hit http://us.archive.ubuntu.com trusty-backports/restricted i386 Packages
Hit http://us.archive.ubuntu.com trusty-backports/universe i386 Packages
Hit http://us.archive.ubuntu.com trusty-backports/multiverse i386 Packages
Hit http://us.archive.ubuntu.com trusty-backports/main Translation-en
Hit http://us.archive.ubuntu.com trusty-backports/multiverse Translation-en
Hit http://us.archive.ubuntu.com trusty-backports/restricted Translation-en
Hit http://us.archive.ubuntu.com trusty-backports/universe Translation-en
Ign http://us.archive.ubuntu.com trusty/main Translation-en_US
Ign http://us.archive.ubuntu.com trusty/multiverse Translation-en_US
Ign http://us.archive.ubuntu.com trusty/restricted Translation-en_US
Ign http://us.archive.ubuntu.com trusty/universe Translation-en_US
Fetched 1,217 kB in 8s (151 kB/s)
Reading package lists... Done
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 227G 20G 196G 9% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
udev 1.5G 4.0K 1.5G 1% /dev
tmpfs 297M 1.3M 295M 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 1.5G 21M 1.5G 2% /run/shm
none 100M 32K 100M 1% /run/user

Ok looking good. If you run :

sudo apt-get upgrade

Is it ok?

max (maxgolding1) said : #4

No, there are errors:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  linux-generic linux-generic-pae linux-headers-generic
  linux-headers-generic-pae linux-image-generic linux-image-generic-pae
The following packages will be upgraded:
  apt apt-transport-https apt-utils chromium-codecs-ffmpeg-extra dbus dbus-x11
  libapt-inst1.5 libapt-pkg4.12 libdbus-1-3 libnspr4 libnspr4-0d libnss3
  libnss3-1d libnss3-nssdb linux-libc-dev wine-compholio wine-compholio-i386
17 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
9 not fully installed or removed.
Need to get 25.3 MB of archives.
After this operation, 139 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main libapt-pkg4.12 i386 1.0.1ubuntu2.4.1 [634 kB]
Get:2 http://ppa.launchpad.net/pipelight/stable/ubuntu/ trusty/main wine-compholio i386 1.7.27~ubuntu14.04.1 [2,637 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main apt i386 1.0.1ubuntu2.4.1 [953 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main libapt-inst1.5 i386 1.0.1ubuntu2.4.1 [58.4 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main libdbus-1-3 i386 1.6.18-0ubuntu4.2 [132 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/universe chromium-codecs-ffmpeg-extra i386 37.0.2062.120-0ubuntu0.14.04.1~pkg1049 [837 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/universe libnspr4-0d i386 2:4.10.7-0ubuntu0.14.04.1 [6,586 B]
Get:8 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main libnspr4 i386 2:4.10.7-0ubuntu0.14.04.1 [111 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main libnss3-1d i386 2:3.17-0ubuntu0.14.04.1 [9,308 B]
Get:10 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main libnss3-nssdb all 2:3.17-0ubuntu0.14.04.1 [10.6 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main libnss3 i386 2:3.17-0ubuntu0.14.04.1 [1,055 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main apt-utils i386 1.0.1ubuntu2.4.1 [172 kB]
Get:13 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main apt-transport-https i386 1.0.1ubuntu2.4.1 [25.4 kB]
Get:14 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main dbus i386 1.6.18-0ubuntu4.2 [233 kB]
Get:15 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main dbus-x11 i386 1.6.18-0ubuntu4.2 [18.5 kB]
Get:16 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main linux-libc-dev i386 3.13.0-36.63 [795 kB]
Get:17 http://ppa.launchpad.net/pipelight/stable/ubuntu/ trusty/main wine-compholio-i386 i386 1.7.27~ubuntu14.04.1 [17.6 MB]
Fetched 25.3 MB in 14s (1,799 kB/s)
(Reading database ... 213971 files and directories currently installed.)
Preparing to unpack .../libapt-pkg4.12_1.0.1ubuntu2.4.1_i386.deb ...
Unpacking libapt-pkg4.12:i386 (1.0.1ubuntu2.4.1) over (1.0.1ubuntu2.3) ...
Setting up libapt-pkg4.12:i386 (1.0.1ubuntu2.4.1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.3) ...
(Reading database ... 213971 files and directories currently installed.)
Preparing to unpack .../apt_1.0.1ubuntu2.4.1_i386.deb ...
Unpacking apt (1.0.1ubuntu2.4.1) over (1.0.1ubuntu2.3) ...
Processing triggers for man-db (2.6.7.1-1) ...
Setting up apt (1.0.1ubuntu2.4.1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.3) ...
(Reading database ... 213971 files and directories currently installed.)
Preparing to unpack .../libapt-inst1.5_1.0.1ubuntu2.4.1_i386.deb ...
Unpacking libapt-inst1.5:i386 (1.0.1ubuntu2.4.1) over (1.0.1ubuntu2.3) ...
Preparing to unpack .../libdbus-1-3_1.6.18-0ubuntu4.2_i386.deb ...
Unpacking libdbus-1-3:i386 (1.6.18-0ubuntu4.2) over (1.6.18-0ubuntu4.1) ...
Preparing to unpack .../chromium-codecs-ffmpeg-extra_37.0.2062.120-0ubuntu0.14.04.1~pkg1049_i386.deb ...
Unpacking chromium-codecs-ffmpeg-extra (37.0.2062.120-0ubuntu0.14.04.1~pkg1049) over (37.0.2062.94-0ubuntu0.14.04.1~pkg1042) ...
Preparing to unpack .../libnspr4-0d_2%3a4.10.7-0ubuntu0.14.04.1_i386.deb ...
Unpacking libnspr4-0d:i386 (2:4.10.7-0ubuntu0.14.04.1) over (2:4.10.2-1ubuntu1.1) ...
Preparing to unpack .../libnspr4_2%3a4.10.7-0ubuntu0.14.04.1_i386.deb ...
Unpacking libnspr4:i386 (2:4.10.7-0ubuntu0.14.04.1) over (2:4.10.2-1ubuntu1.1) ...
Preparing to unpack .../libnss3-1d_2%3a3.17-0ubuntu0.14.04.1_i386.deb ...
Unpacking libnss3-1d:i386 (2:3.17-0ubuntu0.14.04.1) over (2:3.15.4-1ubuntu7.1) ...
Preparing to unpack .../libnss3-nssdb_2%3a3.17-0ubuntu0.14.04.1_all.deb ...
Unpacking libnss3-nssdb (2:3.17-0ubuntu0.14.04.1) over (2:3.15.4-1ubuntu7.1) ...
Preparing to unpack .../libnss3_2%3a3.17-0ubuntu0.14.04.1_i386.deb ...
Unpacking libnss3:i386 (2:3.17-0ubuntu0.14.04.1) over (2:3.15.4-1ubuntu7.1) ...
Preparing to unpack .../wine-compholio_1.7.27~ubuntu14.04.1_i386.deb ...
Unpacking wine-compholio (1.7.27~ubuntu14.04.1) over (1.7.26~ubuntu14.04.1) ...
Preparing to unpack .../wine-compholio-i386_1.7.27~ubuntu14.04.1_i386.deb ...
Unpacking wine-compholio-i386 (1.7.27~ubuntu14.04.1) over (1.7.26~ubuntu14.04.1) ...
Preparing to unpack .../apt-utils_1.0.1ubuntu2.4.1_i386.deb ...
Unpacking apt-utils (1.0.1ubuntu2.4.1) over (1.0.1ubuntu2.3) ...
Preparing to unpack .../apt-transport-https_1.0.1ubuntu2.4.1_i386.deb ...
Unpacking apt-transport-https (1.0.1ubuntu2.4.1) over (1.0.1ubuntu2.3) ...
Preparing to unpack .../dbus_1.6.18-0ubuntu4.2_i386.deb ...
Unpacking dbus (1.6.18-0ubuntu4.2) over (1.6.18-0ubuntu4.1) ...
Preparing to unpack .../dbus-x11_1.6.18-0ubuntu4.2_i386.deb ...
Unpacking dbus-x11 (1.6.18-0ubuntu4.2) over (1.6.18-0ubuntu4.1) ...
Preparing to unpack .../linux-libc-dev_3.13.0-36.63_i386.deb ...
Unpacking linux-libc-dev:i386 (3.13.0-36.63) over (3.13.0-35.62) ...
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for ureadahead (0.100.0-16) ...
ureadahead will be reprofiled on next reboot
Setting up dictionaries-common (1.20.5) ...
update-default-wordlist: Question empty but elements installed for class "wordlist"
  dictionaries-common/default-wordlist: return code: "0", value: ""
  Choices: , Manual symlink setting
  shared/packages-wordlist: return code: "10" owners/error: "shared/packages-wordlist doesn't exist"
  Installed elements: american (American English), british (British English)

  Please see "/usr/share/doc/dictionaries-common/README.problems", section
  "Debconf database corruption" for recovery info.

update-default-wordlist: Selected wordlist ""
does not correspond to any installed package in the system
and no alternative wordlist could be selected.
dpkg: error processing package dictionaries-common (--configure):
 subprocess installed post-installation script returned error exit status 255
dpkg: dependency problems prevent configuration of aspell:
 aspell depends on dictionaries-common (>> 0.40); however:
  Package dictionaries-common is not configured yet.

dpkg: error processing package aspell (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          dpkg: dependency problems prevent configuration of aspell-en:
 aspell-en depends on aspell (>= 0.60.3-2); however:
  Package aspell is not configured yet.
 aspell-en depends on dictionaries-common (>= 0.49.2); however:
  Package dictionaries-common is not configured yet.

dpkg: error processing package aspell-en (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          dpkg: dependency problems prevent configuration of hyphen-en-us:
 hyphen-en-us depends on dictionaries-common (>= 0.10) | openoffice.org-updatedicts; however:
  Package dictionaries-common is not configured yet.
  Package openoffice.org-updatedicts is not installed.
  Package dictionaries-common which provides openoffice.org-updatedicts is not configured yet.

dpkg: error processing package hyphen-en-us (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of myspell-en-au:
 myspell-en-au depends on dictionaries-common (>= 1.0); however:
  Package dictionaries-common is not configured yet.

dpkg: error processing package myspell-en-au (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of myspell-en-gb:
 myspell-en-gb depends on dictionaries-common (>= 0.10) | openoffice.org-updatedicts; however:
  Package dictionaries-common is not configured yet.
  Package openoffice.org-updatedicts is not installed.
  Package dictionaries-common which provides openoffice.org-updatedicts is not configured yet.

dpkg: error processing package myspell-en-gb (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of myspell-en-za:
 myspell-en-za depends on dictionaries-common (>= 0.10) | openoffice.org-updatedicts; however:
  Package dictionaries-common is not configured yet.
  Package openoffice.org-updatedicts is not installed.
  Package dictionaries-common which provides openoffice.org-updatedicts is not configured yet.

dpkg: error processing package myspell-en-za (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of mythes-en-us:
 mythes-en-us depends on dictionaries-common (>= 0.10) | openoffice.org-updatedicts; however:
  Package dictionaries-common is not configured yet.
  Package openoffice.org-updatedicts is not installed.
  Package dictionaries-common which provides openoffice.org-updatedicts is not configured yet.

dpkg: error processing package mythes-en-us (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              dpkg: dependency problems prevent configuration of openoffice.org-hyphenation:
 openoffice.org-hyphenation depends on dictionaries-common (>= 0.10) | openoffice.org-updatedicts; however:
  Package dictionaries-common is not configured yet.
  Package openoffice.org-updatedicts is not installed.
  Package dictionaries-common which provides openoffice.org-updatedicts is not configured yet.

dpkg: error processing package openoffice.org-hyphenation (--configure):
 dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
                                                              Setting up libapt-inst1.5:i386 (1.0.1ubuntu2.4.1) ...
Setting up libdbus-1-3:i386 (1.6.18-0ubuntu4.2) ...
Setting up chromium-codecs-ffmpeg-extra (37.0.2062.120-0ubuntu0.14.04.1~pkg1049) ...
Setting up libnspr4:i386 (2:4.10.7-0ubuntu0.14.04.1) ...
Setting up libnspr4-0d:i386 (2:4.10.7-0ubuntu0.14.04.1) ...
Setting up wine-compholio-i386 (1.7.27~ubuntu14.04.1) ...
procps stop/waiting
Setting up wine-compholio (1.7.27~ubuntu14.04.1) ...
Setting up apt-utils (1.0.1ubuntu2.4.1) ...
Setting up apt-transport-https (1.0.1ubuntu2.4.1) ...
Setting up dbus (1.6.18-0ubuntu4.2) ...
Installing new version of config file /etc/dbus-1/session.conf ...
Setting up dbus-x11 (1.6.18-0ubuntu4.2) ...
Setting up linux-libc-dev:i386 (3.13.0-36.63) ...
Setting up libnss3-nssdb (2:3.17-0ubuntu0.14.04.1) ...
Setting up libnss3:i386 (2:3.17-0ubuntu0.14.04.1) ...
Setting up libnss3-1d:i386 (2:3.17-0ubuntu0.14.04.1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.3) ...
Errors were encountered while processing:
 dictionaries-common
 aspell
 aspell-en
 hyphen-en-us
 myspell-en-au
 myspell-en-gb
 myspell-en-za
 mythes-en-us
 openoffice.org-hyphenation
E: Sub-process /usr/bin/dpkg returned an error code (1)

Are there any bugs reported with similar issues?

max (maxgolding1) said : #6

I don't know what you mean.

Manfred Hampl (m-hampl) said : #7

Try the following terminal command

sudp dpkg -i /var/cache/apt/archives/dictionaries-common_1.20.5_all.deb

and copy/paste all output as done before.

max (maxgolding1) said : #8

dpkg: error processing archive /var/cache/apt/archives/dictionaries-common_1.20.5_all.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/dictionaries-common_1.20.5_all.deb

Manfred Hampl (m-hampl) said : #9

ok, try again with the following commands

sudo apt-get install --reinstall --download-only dictionaries-common
ls -l /var/cache/apt/archives/dictionaries-common*
sudo dpkg -i /var/cache/apt/archives/dictionaries-common_1.20.5_all.deb

and copy/paste all output as done before.

max (maxgolding1) said : #10

Is that 3 lines of commands, or are the two sudos two separate commands?

Manfred Hampl (m-hampl) said : #11

Three separate commands, two of them starting with sudo and one starting with ls

max (maxgolding1) said : #12

OK, after first command:

Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 27 not upgraded.
9 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Download complete and in download only mode

After second command:

ls: cannot access /var/cache/apt/archives/dictionaries-common*: No such file or directory

After third:

dpkg: error processing archive /var/cache/apt/archives/dictionaries-common_1.20.5_all.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/dictionaries-common_1.20.5_all.deb

Manfred Hampl (m-hampl) said : #13

I cannot really understand why that file cannot be found on your system after downloading, maybe there is somewhere a typo error, but I cannot see it. Anyhow, try:

sudo apt-get install --reinstall dictionaries-common

If that fails with error messages, try

sudo /usr/share/debconf/fix_db.pl

Copy/paste all output into this question document as done before.

max (maxgolding1) said : #14

first one:

Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 27 not upgraded.
9 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
E: Internal Error, No file name for dictionaries-common:i386

second one:

after i run the prompt it just opens for a new prompt with the cursor blinking. i can't tell if it actually did anything.

Manfred Hampl (m-hampl) said : #15

No output usually is a sign that something went well.

Next attempt:

sudo dpkg --purge dictionaries-common
sudo apt-get install dictionaries-common

and copy/paste all output as done before.

max (maxgolding1) said : #16

dpkg: dependency problems prevent removal of dictionaries-common:
 wbritish depends on dictionaries-common (>= 0.20).
 hunspell-en-us depends on dictionaries-common (>= 0.10).

dpkg: error processing package dictionaries-common (--purge):
 dependency problems - not removing
Errors were encountered while processing:
 dictionaries-common

Reading package lists... Done
Building dependency tree
Reading state information... Done
dictionaries-common is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 27 not upgraded.
9 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up dictionaries-common (1.20.5) ...
Processing triggers for dictionaries-common (1.20.5) ...
aspell-autobuildhash: processing: en [en-common]
aspell-autobuildhash: processing: en [en-variant_0]
aspell-autobuildhash: processing: en [en-variant_1]
aspell-autobuildhash: processing: en [en-variant_2]
aspell-autobuildhash: processing: en [en-w_accents-only]
aspell-autobuildhash: processing: en [en-wo_accents-only]
aspell-autobuildhash: processing: en [en_CA-variant_0]
aspell-autobuildhash: processing: en [en_CA-variant_1]
aspell-autobuildhash: processing: en [en_CA-w_accents-only]
aspell-autobuildhash: processing: en [en_CA-wo_accents-only]
aspell-autobuildhash: processing: en [en_GB-ise-w_accents-only]
aspell-autobuildhash: processing: en [en_GB-ise-wo_accents-only]
aspell-autobuildhash: processing: en [en_GB-ize-w_accents-only]
aspell-autobuildhash: processing: en [en_GB-ize-wo_accents-only]
aspell-autobuildhash: processing: en [en_GB-variant_0]
aspell-autobuildhash: processing: en [en_GB-variant_1]
aspell-autobuildhash: processing: en [en_US-w_accents-only]
aspell-autobuildhash: processing: en [en_US-wo_accents-only]
Setting up hyphen-en-us (2.8.6-3ubuntu2) ...
Setting up myspell-en-au (2.1-5.4) ...
Setting up myspell-en-gb (1:4.2.1-0ubuntu1) ...
Setting up myspell-en-za (1:4.2.1-0ubuntu1) ...
Setting up mythes-en-us (1:4.2.1-0ubuntu1) ...
Setting up openoffice.org-hyphenation (0.7) ...
Setting up aspell (0.60.7~20110707-1ubuntu1) ...
Processing triggers for dictionaries-common (1.20.5) ...
Setting up aspell-en (7.1-0-1) ...
Processing triggers for dictionaries-common (1.20.5) ...

Manfred Hampl (m-hampl) said : #17

Even if my first command did not work and resulted in an error, the second one seems to have finally resolved the problem with the dictionary packages.

Now try

sudo apt-get update
sudo apt-get dist-upgrade

to check whether the package management processes work again.

max (maxgolding1) said : #18

Problem solved! Thank you!