Software update has stopped working

Asked by Greg on 2014-08-18

Been running 12.04 LTS for many months ok. Decided to install Dropbox and although it appeared to install, the Ubuntu Software Centre app under the Progress tab, states that it is searching and remains in that state.
When I try to run software update, I get a pop-up stating "Not all updates can be installed" and provides a "Partial Update" button. Clicking that gives a pop-up stating "unable to get exclusive lock" and suggests: "This usually means that another package management application (like apt-get or aptitude) already running. Please close that application first."
I have tried some of the solutions in FAQ but get similar error messages ie can't get exclusive lock.

Please help.
Started the trouble shooting procedure for Package Manager, step 5 terminal output follows:
greg@Raven:~$ ubuntu-support-status
Support status summary of 'Raven':

You have 1810 packages (100.0%) that can not/no-longer be downloaded
You have 0 packages (0.0%) that are unsupported

Your current Hardware Enablement Stack (HWE) is no longer supported
since 2014-08-07. Security updates for critical parts (kernel
and graphics stack) of your system are no longer available.

For more information, please see:
http://wiki.ubuntu.com/1204_HWE_EOL

To upgrade to a supported (or longer supported) configuration:

* Upgrade from Ubuntu 12.04 LTS to Ubuntu 14.04 LTS by running:
sudo do-release-upgrade

OR

* Install a newer HWE version by running:
sudo apt-get install linux-generic-lts-trusty libgl1-mesa-glx-lts-trusty xserver-xorg-lts-trusty linux-image-generic-lts-trusty

and reboot your system.

Run with --show-unsupported, --show-supported or --show-all to see more details
greg@Raven:~$

>> tried to install the newer HWE with above command string but this failed with error message:
"E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?"

I'll wait for some feedback before going any further with the trouble shooting procedure.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu software-center Edit question
Assignee:
No assignee Edit question
Solved by:
Greg
Solved:
2014-08-19
Last query:
2014-08-19
Last reply:
2014-08-18

Be sure to close any GUI applications that use packages because (as on Windows) only one application can use the packages at once. Software centre will lock the packages simply by being open. If this is not the case, try rebooting but if you still have the issue in terminal then run:

 sudo fuser -vki /var/lib/dpkg/lock;sudo dpkg --configure -a

And it will resolve the problem.

Thanks

Greg (gjkendall) said : #2

Thanks Andrew,
Followed your steps with the following results:
greg@Raven:~$ sudo fuser -vki /var/lib/dpkg/lock;sudo dpkg --configure -a
[sudo] password for greg:
                     USER PID ACCESS COMMAND
/var/lib/dpkg/lock: root 2594 F.... dpkg
Kill process 2594 ? (y/N) y
Setting up nautilus-dropbox (0.7.1-2) ...

Downloading Dropbox... 100% o share and store your files online. Want to learn more? Head to http://www.dropbox.com/

>>The download counts up to 100% and the terminal window hangs at that point, ie does not respond to exit command.
It seems like Dropbox is keeping the Software Manager running. I tried using the Software Manager to remove Dropbox but that also seems to hang.
What should I try next?

Greg (gjkendall) said : #3

Did a bit more reading and managed to fix. used dpkg in terminal to emove the dropbox package which was showing code of "iF" in dpkg. This gave me control back so iI immediately did the upgrade to 14.04. Its working but seems very slow so now need to investigate that ...lol.