In middle of updating VirtualBox, my pc lost power. Now, the s/w library is broken

Asked by Howard Brodale on 2014-04-14

On Unity bar is a red circle with a white dash thats says:

 An error occurred, please Package Manager from the right-click menu or apt-get in a terminal to see whats wring. The error message was: 'Unknown Error: 'ctype' exceptons.SystemError'>'(E:The package virtualbox-4.3 needs to be reinstalled, but I can't find an archive for it.)'. Thus usually means that your installed packages have unmet dependencies.

 Clicking on the downloaded update file opens up the s/w library again but, then it quickly locks up wth the statuses not moving.

  When trying to open the Ubuntu Software Center (s/w libray) the gui appears for about as long then disappears.

  When trying Software Updates in opens but then as quickly posts the same error:

An unresolvable problem occurred while initializing the package information.

Please report this bug against the 'update-manager' package and include the following error message:

'E:The package virtualbox-4.3 needs to be reinstalled, but I can't find an archive for it.'

 So, I can't open the Ubuntu Software Center to reinstall virtualbox! This is a catch-22 situation! That can't be solved right now!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu software-center Edit question
Assignee:
No assignee Edit question
Solved by:
Howard Brodale
Solved:
2014-04-17
Last query:
2014-04-17
Last reply:
2014-04-15

Try:

sudo apt-get -f install

Manfred Hampl (m-hampl) said : #2

If actionparsnips' advice does not help, please provide the output of the terminal commands

apt-cache policy virtualbox-4.3
ls -l /var/cache/apt/archives/virtualbox*

Howard Brodale (brodhow-w) said : #3

I issued a -remove -force dpkg command because no install command would work. Then, i reinstalled vbox normally successfully.