Internal language problem or hardware problem that stops me from linking a CSS file to a HTML file or programming from the terminal in C .

Asked by Jonathan Todd on 2014-02-18

Hi, Folks:
                 I recieved a refurbished computer from Free Geek and when I took it home a flasher came on telling me I had an internal language problem. I tried attaching a CSS file to a HTML file and was unsuccessful. I was also unsuccessful at creating a C compiler while trying to program from the terminal and got a message saying the operation could not be performed. The computer is psrogrammed in Linux Ubuntu. I don't know if I have a software problem, or if something is wrong with the computer hardware.

                                                                                                                                                                          Jonathan Todd

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu software-center Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2014-02-20
Last query:
2014-02-20
Last reply:
2014-02-19

What is the output of :

sudo apt-get update; lsb_release -a

Thanks

Jonathan Todd (stenchwrench-p) said : #2

Lame, but I forgot how to get into the terminal. They want a password

On Mon, Feb 17, 2014 at 11:26 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #244164 on software-center in Ubuntu changed:
>
> https://answers.launchpad.net/ubuntu/+source/software-center/+question/244164
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> What is the output of :
>
> sudo apt-get update; lsb_release -a
>
> Thanks
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
>
> https://answers.launchpad.net/ubuntu/+source/software-center/+question/244164
>
> You received this question notification because you asked the question.
>

You don't need a password to get in to the terminal. You press CTRL + ALT + T and one runs. You are now in the terminal. No password is needed to run the terminal however you will need your login password to run the command and you will not get any visual feedback as you type it.

Jonathan Todd (stenchwrench-p) said : #4

The output of:

sudo apt-get update; lsb_release-a is command not found

Ok what is the output of :

cat /etc/issue

Thanks

Jonathan Todd (stenchwrench-p) said : #6

The output is:
no such file or directory

There is a space between the word 'cat' and the file. If you COPY and paste the command line to the terminal you won't botch the command.

Jonathan Todd (stenchwrench-p) said : #8

The output is:

Ubuntu 12.04 LTS \n\l

Ok, now again copy the command and run it:

sudo apt-get update

What is the full output please?

Hi, I have to confess something, I'm a total technopeasant. I don't know how to copy and paste, though I've heard other people use the term many times. Thanks for your patience.

                                                                                                         Jonathan Todd

Hi, I may have misunderstood "copy". I ran the command you gave me and it fetched 2,684 kB and then said that it was done reading the package lists

I went ahead trying to build a compiler using gcc and the output was:
fatal error:no input files
compolation terminated

To copy the text its like in any text editor.

 I don't know how to copy the text in a text editor.

I went online to learn how to copy, dragged the cursor across the command, right clicked and clicked on copy, then ran sudo apt-get update. The full output was:
reading package lists...done
jonathan@possibility:~$

 Tried to build the compiler again, typed gcc and got gcc:fatal error:no input files
compilation terminated

Best Manfred Hampl (m-hampl) said : #17

Can you please explain what you exactly want to achieve?

You write "Tried to build the compiler" - Well there should not be any need to build a compiler, because the C and C++ compilers are already delivered with a standard Ubuntu installation.

If you just issue the terminal command "gcc" without any further options and file names, it of course will fail, because you instruct the compiler to process an input file but do not provide any.

For copy/paste from a terminal:
Most people are used to pressing Ctrl-c / Ctrl-x / Ctrl-v for copy / cut / paste. These are also the standard key combinations on Ubuntu with the exception of a terminal window. In a terminal window you have to use Shift-Ctrl-c / Shift-Ctrl-x / Shift-Ctrl-v or use the terminal window's menu entries ("Edit - Select all", "Edit - Copy" and "Edit - Paste").

Thanks Manfred Hampl, that solved my question.

Hi Manfred and Andrew!

                                                 I pressed "this solved my problem" and the last message was posted, which serendipidously expressed my sentiments exactly. Thanks to both of you guys, especially you, Andrew for your patience and persistence. I'll persevere and explore. I may be back in touch if I need more assistance. Thanks again!

                                                                                                       Jonathan Todd