What is openafs and how do I configure it?

Asked by Dean von Germeten on 2013-08-28

I downloaded and tried to install Camera.app 0.8.0-9build1. The installation failed, details said re: dependencies, I have yet to configure openafs. I don't know what that is or where to find it or how to configure it. I'm using Ubuntu 12.04 LTS.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu software-center Edit question
Assignee:
No assignee Edit question
Solved by:
Dean von Germeten
Solved:
2013-09-12
Last query:
2013-09-12
Last reply:
2013-08-30
Thomas Krüger (thkrueger) said : #1

OpenAFS is a distributed file system which is used in large networks, like Universities or large Enterprises. It is something that, except of a few exotic cases, no home user ever needs to configure.

The installation works fine on my system. I guess there is something wrong with your setup. Can you try to install from the Terminal and post the full output? To do so, open the Terminal application an run the command:

sudo apt-get install camera.app

Then copy the full output.

Dean von Germeten (germeten-i) said : #2

root@deanvon-home:/home/deanvon# sudo apt-get install camera.app
Reading package lists... Done
Building dependency tree
Reading state information... Done
camera.app is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? Y
Setting up openafs-client (1.6.1-1+ubuntu0.2) ...
dpkg: error processing openafs-client (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of openafs-fileserver:
 openafs-fileserver depends on openafs-client; however:
  Package openafs-client is not configured yet.
dpkg: error processing openafs-fileserver (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          Errors were encountered while processing:
 openafs-client
 openafs-fileserver
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@deanvon-home:/home/deanvon#

Thomas Krüger (thkrueger) said : #3

Camera.app is installed already. But you have an broken installation of OpenAFS. You should try to remove it:
sudo apt-get purge openafs-fileserver openafs-client

Dean von Germeten (germeten-i) said : #4

If I remove it and it goes away, how do I get it back? Thanks!

Dean von Germeten (germeten-i) said : #5

My tech bud followed your instructions and got it working, he reinstalled some stuff, don't know how or what, so the problem is solved, but I don't think I'm any wiser!