Software Center won't connect for ToS

Asked by Josh Rutledge on 2013-08-22

when I go to buy something in the software center it won't connect for the terms of service. For some reason it won't let me, but only if it says "Buy" and not "install", even if it doesn't cost anything. I get this error message:
"Unable to load page

Problem occurred while loading the URL https://apps.ubuntu.com/cat/tos/plain/

Cannot resolve proxy hostname ()"

Please let me know if I'm doing something wrong or if there's something I can do to fix this. (I just started using Ubuntu today and the only other OS I've used is windows.)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu software-center Edit question
Assignee:
No assignee Edit question
Last query:
2013-08-22
Last reply:
2013-08-22

Do you use a proxy to get web access?
What is the output of:

uname -a; cat /etc/issue

Thanks

Please try this solution:

https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/987881/comments/7

If that does not help, please close all open programs (including Software Center) and send us the full Terminal output of the commands in step 5 in the following procedure:

https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure

Please post full Terminal output here:

https://answers.launchpad.net/ubuntu/+source/software-center/+question/234427

Can you help with this problem?

Provide an answer of your own, or ask Josh Rutledge for more information if necessary.

To post a message you must log in.