Need 32 bit libs on 64 bit Ubuntu 12.04

Asked by Phil Gillaspy on 2012-11-01

The getlibs script previously posted in this post

https://answers.launchpad.net/ubuntu/+question/120295

need 32 bit development libs on 64 bit lucid (Answered)
 is no longer available at http://frozenfox.freehostia.com/cappy/.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu software-center Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
Last query:
Last reply:
Revision history for this message
marcobra (Marco Braida) (marcobra) said :
#1
Revision history for this message
Best marcobra (Marco Braida) (marcobra) said :
#2

to made some check before installing, from terminal:

mkdir $HOME/getlibs_package
cd $HOME/getlibs_package
wget http://usablesoftware.files.wordpress.com/2011/02/getlibs-all-deb.pdf
mv getlibs-all-deb.pdf getlibs-all.deb

To check the content of package downloaded from this unsecure address...

dpkg -c getlibs-all.deb

We extract to temp dir

dpkg -x getlibs-all.deb /tmp/getlibs

and we can inspect the getlibs shell script

gedit /tmp/getlibs/usr/bin/getlibs

Then you can install it with

sudo dpkg -i getlibs-all.deb

Revision history for this message
Phil Gillaspy (phgphd) said :
#3

Marco, I have followed your instructions. I am not sure what gedit /tmp/getlibs/usr/bin/getlibs was suppose to do as there was no such file. But I continued on, and did the dpkg -i and it appears the install went well. The install did not indicate where the files are installed. I ran a 32-bit app and it failed to run indicating that it could not find a file it needed (presumably a lib).

Revision history for this message
Phil Gillaspy (phgphd) said :
#4

No I am mistaken there is a file /tmp/getlibs/usr/bin/getlibs,

Revision history for this message
Phil Gillaspy (phgphd) said :
#5

I looked at getlibs and decided to do
sudo apt-get install ia32-libs
apt-get said all libs were already installed and up to date.

Revision history for this message
Phil Gillaspy (phgphd) said :
#6

I did a getlibs against my 32-bit app and it said all dependencies are satisifed. I'll consider my question answered. Thanks for sharing your time and knowledge.