Where do you specify the proxy config so Ubuntu Software Center honors the proxy settings?

Asked by Calvin S

No matter what I set the network proxy settings under the "System Settings" --> "Network" to, then Ubuntu Software Center ignores the proxy config. I have even tried setting environment variables "http_proxy", "HTTP_PROXY", "https_proxy", and "HTTPS_PROXY". None of the above options worked; *all* options error out.

I then unset the environment variables and issued "wget --verbose http://{some-long-path-to-a-valid-DEB-package}". Ta-da! Exact same error message as Ubuntu Software Center.

After resetting the environment variables, I then ran "wget --verbose http://{some-long-path-to-a-valid-DEB-package}" again. Guess what happened? That's right, it _worked_!

Conclusion: Ubuntu Software Center is not honoring *any* proxy configs on my system.

So I ask again, where do you specify the proxy config so Ubuntu Software Center honors the proxy settings?

Question information

English Edit question
Ubuntu software-center Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
marcobra (Marco Braida) (marcobra) said :

Please set your proxy into file /etc/apt/apt.conf

Try creating a file /etc/apt/apt.conf with the following contents:

Acquire::http::Proxy "http://myusername:$<email address hidden>:3128/";

or if you don't need user and password:

Acquire::http::Proxy "http://proxy_address:3128/";

That should work for any apt invocation, whether it is through the command line, synaptic or update-manager.

To create file from terminale type:

gksudo gedit /etc/apt/apt.conf

Revision history for this message
Siddhant Saraf (siddhantsaraf) said :


Acquire::http::Proxy "http://myusername:$<email address hidden>:3128/";

what is that dollar-sign before 'mypassword' donig there? I think that is not needed.

Revision history for this message
Rushi Agrawal (rushiagr) said :

Dollar sign not required.

Can you help with this problem?

Provide an answer of your own, or ask Calvin S for more information if necessary.

To post a message you must log in.