Wordfast in Ubuntu 11.04 x 64

Asked by Irina Tokna on 2011-07-17

I've just installed Ubuntu 11.04 x64 and tried to install programm Wordfast (wordfast.com).
Well... the Linux version of Wordfast simply would not open (when I click on it, it suggest to "Execute", "Execute in Terminal" or "Cancel". The Execute button does nothing at all, the Execute in Terminal opens the terminal, and I wonder if there's a way to open Wordfast this way (I am new to the Terminal commands so far).

I've installed the Windows version under Wine, yet it does not work properly either (Wordfast opens, but neither there is the standard command menu at the top, nor it would open the file with the "Open with" command).

This is the only problem I have with the new system, and I wonder, whether I should return to Mandriva Linux (Wordfast worked fine on it), or I can make it work with Ubuntu. (I am now digging through everything I can find about Wordfast+Ubuntu in the search, but it's of a little help so far).

Thank you in advance for any suggestions.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu software-center Edit question
Assignee:
No assignee Edit question
Solved by:
Irina Tokna
Solved:
2011-07-17
Last query:
2011-07-17
Last reply:
Mehman Jamalov (mcamalov) said : #1

I think there is not a linux version of wordfast software in its site, thats why you have to install wine and winetricks for installing it. Install winetricks and you have to install some windows dll files. just search "winetricks" in youtube, and "configure wine" in google.

Irina Tokna (tokkna) said : #2

sorry, I did not give a link to the download page
http://wordfast.com/store_download.html

and supported platforms page
http://wordfast.com/support_platforms.html

it is available for Linux (and I used the Linux version on Mandriva Linux)

Thank you for the suggestion about winetricks - I installed only wine, and no additional wine programs. Thanks, I'll try it now

Irina Tokna (tokkna) said : #3

I removed the 64-bit Ubuntu and installed the 32-bit Ubuntu.

Now Linux version of Wordfast works!

Thanks and good luck!

The GNU/Linux version of Wordfast Pro is actually a Java program in a Linux executable wrapper. Since the 64-bit version of Ubuntu is capable of running 32-bit Linux programs (you might just have to install the necessary 32-bit libraries to make them work, which, for the most commonly needed libraries, are provided as easily installable Ubuntu packages), and Java is very cross-platform anyway, I don't know why it didn't work on the 64-bit system but worked out of the box on the 32-bit system. Wordfast Pro crashes on my 64-bit system, but it *crashes*--that is, it *runs*, and it encounters an unhandled exception, and terminates. That may have been what happened for you, but if your 32-bit Ubuntu system is otherwise similar to your 64-bit Ubuntu system, why wouldn't it crash on the 32-bit system too?

If you are using proprietary version of Java (sun-java6) rather than the free open source version (openjdk-6) which is equally official (but for some reason people think sun-java6 is better...and it is for some applications, but not in general), then the reason for your inability to run Wordfast on a 64-bit Ubuntu system might be very simple--with sun-java6, you generally need to have the ia32-sun-java6-bin package installed in order to run Java code embedded in (or existing as a plugin for) 32-bit executables.

Irina Tokna (tokkna) said : #5

Thank you for your reply.

I am a plain user and don't understand computer processes well, but I did install 32-bit Java libraries (got necessary commands from a different forum). Wordfast would not even OPEN even after this.

Now it's the 32-bit system it works without problem. And the system was only downloaded this morning from the Ubuntu site, no special libraries or packets - it's working right from the box, as you said.

I don't know where's the secret, yet... it works - and some users might find it useful.

"I don't know where's the secret, yet... it works - and some users might find it useful."

Indeed, I agree. Thank you for posting your solution!

If you ever need to run Wordfast Pro on a 64-bit Ubuntu system, please feel free to start a new question (or to reopen this one).