How to update adobe flash player

Asked by Sukhendu Ghosal on 2011-07-03

Flash player is showing update is available . But update manager is not showing . No online video is playing. How can I upgrade it.
thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu software-center Edit question
Assignee:
No assignee Edit question
Solved by:
Sukhendu Ghosal
Solved:
2011-07-04
Last query:
2011-07-04
Last reply:
2011-07-03
Massimo Forti (slackwarelife) said : #1

Hi, wich is your flash and ubuntu version? I'm using Ubuntu 11.04 and flash player 10.3.181.26 and all works. But now, on Ubuntu miror, is present the new version of Flash. To update it, you must open update manager. Let me know if you find the update. Thanks many.

I am using kubuntu 11.04

Nothing is showing in the update

Massimo Forti (slackwarelife) said : #4

Hi, have you enabled the restricted repository active in packages management? Thanks

yes that is enabled
thanks

Massimo Forti (slackwarelife) said : #6

Have you installed the adobe-flashplugin-10.3.181.26-0natty1.deb pkg? If you haven't, try to do this:

sudo add-apt-repository "deb http://archive.canonical.com/ natty partner"
sudo apt-get update
sudo apt-get install adobe-flashplugin

or (if you have just installed)

sudo apt-get upgrade

If you have installed other Flash pkg then the once I have suggest, you must uninstall it before do the sequence of command I described in this post. I hope my suggest can help you. Thanks.

Sir,

the output is

sukhendu@Moon:~$ sudo add-apt-repository "deb http://archive.canonical.com/ natty partner"
[sudo] password for sukhendu:
sukhendu@Moon:~$ sudo apt-get update
Ign http://ppa.launchpad.net natty InRelease
Ign http://extras.ubuntu.com natty InRelease
Ign http://archive.canonical.com natty InRelease
Hit http://ppa.launchpad.net natty Release.gpg
Ign http://in.archive.ubuntu.com natty InRelease
Ign http://in.archive.ubuntu.com natty-updates InRelease
Get:1 http://extras.ubuntu.com natty Release.gpg [72 B]
Get:2 http://archive.canonical.com natty Release.gpg [198 B]
Hit http://ppa.launchpad.net natty Release
Hit http://in.archive.ubuntu.com natty Release.gpg
Hit http://extras.ubuntu.com natty Release
Get:3 http://archive.canonical.com natty Release [5,916 B]
Hit http://ppa.launchpad.net natty/main Sources
Hit http://in.archive.ubuntu.com natty-updates Release.gpg
Hit http://extras.ubuntu.com natty/main Sources
Hit http://ppa.launchpad.net natty/main amd64 Packages
Hit http://in.archive.ubuntu.com natty Release
Ign http://ppa.launchpad.net natty/main TranslationIndex
Hit http://extras.ubuntu.com natty/main amd64 Packages
Ign http://extras.ubuntu.com natty/main TranslationIndex
Hit http://in.archive.ubuntu.com natty-updates Release
Get:4 http://archive.canonical.com natty/partner Sources [4,171 B]
Ign http://security.ubuntu.com natty-security InRelease
Hit http://in.archive.ubuntu.com natty/main Sources
Hit http://in.archive.ubuntu.com natty/restricted Sources
Hit http://in.archive.ubuntu.com natty/universe Sources
Hit http://in.archive.ubuntu.com natty/multiverse Sources
Hit http://in.archive.ubuntu.com natty/main amd64 Packages
Get:5 http://archive.canonical.com natty/partner amd64 Packages [6,736 B]
Hit http://security.ubuntu.com natty-security Release.gpg
Hit http://in.archive.ubuntu.com natty/restricted amd64 Packages
Hit http://in.archive.ubuntu.com natty/universe amd64 Packages
Hit http://in.archive.ubuntu.com natty/multiverse amd64 Packages
Ign http://in.archive.ubuntu.com natty/main TranslationIndex
Ign http://in.archive.ubuntu.com natty/multiverse TranslationIndex
Ign http://in.archive.ubuntu.com natty/restricted TranslationIndex
Ign http://in.archive.ubuntu.com natty/universe TranslationIndex
Hit http://in.archive.ubuntu.com natty-updates/main Sources
Hit http://in.archive.ubuntu.com natty-updates/restricted Sources
Hit http://in.archive.ubuntu.com natty-updates/universe Sources
Hit http://security.ubuntu.com natty-security Release
Ign http://archive.canonical.com natty/partner TranslationIndex
Hit http://in.archive.ubuntu.com natty-updates/multiverse Sources
Hit http://in.archive.ubuntu.com natty-updates/main amd64 Packages
Hit http://in.archive.ubuntu.com natty-updates/restricted amd64 Packages
Hit http://in.archive.ubuntu.com natty-updates/universe amd64 Packages
Hit http://in.archive.ubuntu.com natty-updates/multiverse amd64 Packages
Hit http://security.ubuntu.com natty-security/main Sources
Ign http://in.archive.ubuntu.com natty-updates/main TranslationIndex
Ign http://in.archive.ubuntu.com natty-updates/multiverse TranslationIndex
Ign http://in.archive.ubuntu.com natty-updates/restricted TranslationIndex
Hit http://security.ubuntu.com natty-security/restricted Sources
Ign http://in.archive.ubuntu.com natty-updates/universe TranslationIndex
Hit http://security.ubuntu.com natty-security/universe Sources
Hit http://security.ubuntu.com natty-security/multiverse Sources
Hit http://security.ubuntu.com natty-security/main amd64 Packages
Hit http://security.ubuntu.com natty-security/restricted amd64 Packages
Ign http://ppa.launchpad.net natty/main Translation-en_IN
Ign http://ppa.launchpad.net natty/main Translation-en
Hit http://security.ubuntu.com natty-security/universe amd64 Packages
Hit http://security.ubuntu.com natty-security/multiverse amd64 Packages
Ign http://security.ubuntu.com natty-security/main TranslationIndex
Ign http://security.ubuntu.com natty-security/multiverse TranslationIndex
Ign http://security.ubuntu.com natty-security/restricted TranslationIndex
Ign http://security.ubuntu.com natty-security/universe TranslationIndex
Ign http://extras.ubuntu.com natty/main Translation-en_IN
Ign http://extras.ubuntu.com natty/main Translation-en
Ign http://archive.canonical.com natty/partner Translation-en_IN
Ign http://archive.canonical.com natty/partner Translation-en
Ign http://security.ubuntu.com natty-security/main Translation-en_IN
Ign http://security.ubuntu.com natty-security/main Translation-en
Ign http://security.ubuntu.com natty-security/multiverse Translation-en_IN
Ign http://in.archive.ubuntu.com natty/main Translation-en_IN
Ign http://security.ubuntu.com natty-security/multiverse Translation-en
Ign http://in.archive.ubuntu.com natty/main Translation-en
Ign http://in.archive.ubuntu.com natty/multiverse Translation-en_IN
Ign http://security.ubuntu.com natty-security/restricted Translation-en_IN
Ign http://in.archive.ubuntu.com natty/multiverse Translation-en
Ign http://in.archive.ubuntu.com natty/restricted Translation-en_IN
Ign http://in.archive.ubuntu.com natty/restricted Translation-en
Ign http://in.archive.ubuntu.com natty/universe Translation-en_IN
Ign http://in.archive.ubuntu.com natty/universe Translation-en
Ign http://security.ubuntu.com natty-security/restricted Translation-en
Ign http://security.ubuntu.com natty-security/universe Translation-en_IN
Ign http://security.ubuntu.com natty-security/universe Translation-en
Ign http://in.archive.ubuntu.com natty-updates/main Translation-en_IN
Ign http://in.archive.ubuntu.com natty-updates/main Translation-en
Ign http://in.archive.ubuntu.com natty-updates/multiverse Translation-en_IN
Ign http://in.archive.ubuntu.com natty-updates/multiverse Translation-en
Ign http://in.archive.ubuntu.com natty-updates/restricted Translation-en_IN
Ign http://in.archive.ubuntu.com natty-updates/restricted Translation-en
Ign http://in.archive.ubuntu.com natty-updates/universe Translation-en_IN
Ign http://in.archive.ubuntu.com natty-updates/universe Translation-en
Fetched 17.1 kB in 33s (510 B/s)
Reading package lists... Done
sukhendu@Moon:~$ sudo apt-get install adobe-flashplugin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package adobe-flashplugin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'adobe-flashplugin' has no installation candidate
sukhendu@Moon:~$

what should I do now

Sam_ (and-sam) said : #8

adobe-flashplugin doesn't exist, but flashplugin-installer does.
http://packages.ubuntu.com/search?suite=default&section=all&arch=any&searchon=names&keywords=flashplugin-installer

Side note: while working in a terminal close all package management apps, e.g. software-center, synaptic, update-manager.
Before updating switch to main server in software sources, maybe the (in) mirror isn't synced yet.
https://help.ubuntu.com/community/Repositories/Ubuntu#Download%20Server

Then run in a terminal:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get -f install

Massimo Forti (slackwarelife) said : #9

Hi, this is the link of adobe-flashplugin launchpad project: https://launchpad.net/ubuntu/+source/adobe-flashplugin and this pkg are present in the partner repository: http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flash-properties-gtk_10.3.181.34-0natty1_i386.deb. I don't understand way you don't find it in the repository. I try to understand. Thanks.

Massimo Forti (slackwarelife) said : #10

Sorry, this is the right link of deb pkg present in Canonical partner repository: http://archive.canonical.com/pool/partner/a/adobe-flashplugin/adobe-flashplugin_10.3.181.34-0natty1_i386.deb. The other pkg I linked is one of the dependencies necessary. Thanks.

Sir both the link provided by you are for 32 bit but I am using 64 bit . Please provide the link for 64 bit.

yes the problem solved. I have removed all flash packages then

sudo apt-get install flashplugin64-installer

Now everything is ok.

Sam_ (and-sam) said : #13

> I don't understand way you don't find it in the repository

Because I don't have Canonical partner enabled, rather either lookup official repo page or apt-cache.
You can try the link and search unsuccessful flashplugin64-installer and adobe-flashplugin.
http://packages.ubuntu.com/natty/flashplugin-installer
flashplugin-installer is available as 10.3.181.34ubuntu0.11.04.1 which incl. the wrapper for 64bit and downloads it from adobe.