Ubuntu software center not installing/uninstalling

Asked by hohoho

Whenever I try to install or un-install a software program via UBUNTU Software Center, it says
 "Previous installation hasn't been completed.
The installation could have failed because of an error in the corresponding software package or it was cancelled in an unfriendly way. You have to repair this before you can install or remove any further software."
Please help me "fix" the issue, as i am new using UBUNTU, and do not know how

thanks so much
~Ellory L

Question information

English Edit question
Ubuntu software-center Edit question
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Last query:
Last reply:
Revision history for this message
Mario Tomljenović (tomljenovicmario) said :

You have to fix broken packages. Open up System>Administration>Synaptic Package Manager.
Choose Edit > Fix Broken Packages from the menu.
Choose Apply Marked Changes from the Edit menu or press Ctrl + P.
Confirm the summary of changes and click Apply.

Revision history for this message
Best marcobra (Marco Braida) (marcobra) said :

Open a Terminal from the menu Applications->Accessories->Terminal

Tip: right click with mouse on the terminal title caption and select the item "Always on Top" doing this you will force the terminal window to stay on top of the other windows and you will find very easy to copy single row from this web page into the terminal...
Something more about using the terminal https://help.ubuntu.com/community/UsingTheTerminal

Then type or better copy and paste a row a time then press enter:
(Tip: select the single row to copy then right click into the terminal and to quick paste click with middle button of mouse )

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get --fix-missing install
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get clean
sudo apt-get autoremove
sudo apt-get update

give your user password when requested, you don't see nothing when you type it, then press enter.

Hope this helps

Revision history for this message
hohoho (rocketryman) said :

@Mario Tomljenović
when i open the synaptic package manager, it gives me this message
"E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report."

idk wat to do

Revision history for this message
Mario Tomljenović (tomljenovicmario) said :

Do what Marco Braida said. That will solve your problem.

Revision history for this message
hohoho (rocketryman) said :

ok, thanks :)

Revision history for this message
hohoho (rocketryman) said :

Thanks marcobra (Marco Braida), that solved my question.

Revision history for this message
George Myers (george-myers) said :

I also want to thank Marco. I just installed Ubuntu and when I tried installing Flash and another program I received an error dealing with 128. Entered the commands Marco listed and all is working now.