Smartmontools won't start on boot

Asked by itsgnd

I recently noticed that Smartmontools was no longer logging information for my hard drives. I tried running tests using smartctl from the command line and that worked fine. I grepped the running processes and noticed that the smartd daemon was not running. I tried starting it from the command line by issuing "/etc/init.d/smartmontools restart". I received a message saying the the process was stopped OK, but did not receive a message for starting the process. I dug around in the smartmontools startup script, but I don't notice anything wrong. If I issue the command "smartd -c /etc/smartd.conf -p /var/run/ --logfacility=local3" from the command line the daemon loads fine. It looks like it is a problem with the start up script. I have reloaded the original script and config file with no change. Does anyone have any suggestions?

I am running feisty 7.10 with smartmontools release 5.37.


Question information

English Edit question
Ubuntu smartmontools Edit question
No assignee Edit question
Solved by:
Marc D.
Last query:
Last reply:
Revision history for this message
Best Marc D. (koshy) said :

Look at /etc/default/smartmontools, there should be a line (commented out by default):


Revision history for this message
itsgnd (itsgnd) said :

Hmmm, for whatever reason that line wasn't in the smartmontools file. But I added it and it works like a champ!

Thanks for your help.

Revision history for this message
itsgnd (itsgnd) said :

Thanks Marc A. Donges, that solved my question.