skype icon wont appear in the task bar

Asked by Brian Marine on 2012-11-19

i am running a test of ubuntu 12.04 and while running skype i cant see its icon on the task bar.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu skype Edit question
Assignee:
No assignee Edit question
Solved by:
Subin Hutton
Solved:
2012-11-20
Last query:
2012-11-20
Last reply:
2012-11-20

Have you got other icons in the top bar for other running apps?
Have you dragged it to the Unity bar on the left?
What is the output of:

lsb_release -a; uname -a; apt-cache policy skype

Thanks

Brian Marine (crysisfreak7) said : #2

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux User-pc3 3.2.0-33-generic #52-Ubuntu SMP Thu Oct 18 16:29:15 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
skype:i386:
  Installed: 4.1.0.20-1
  Candidate: 4.1.0.20-1
  Version table:
 *** 4.1.0.20-1 0
        100 /var/lib/dpkg/status

Best Subin Hutton (djlynux) said : #3

I was having the same issue, I've resolved this issue by installing skype from ubuntus third party repo.

1 First uninstall, the skype version that you've installed now. O
2. Open software sources, click partners repo(Canonical partner).
3. After that type the following command in a terminal.

sudo apt-get update; sudo apt-get install skype

N1ck 7h0m4d4k15 (nicktux) said : #4

Skype 4.1 is not in Ubuntu Software Center. You downloaded and installed from Skype's site. Correct ? (or from PPA).

Well , remove completely this version

~$ sudo apt-get remove --purge skype*

If you added a PPA , then remove the PPA as well.

Then enable the Partners Repo in Ubuntu

~$ gksudo software-properties-gtk

Go to "other software" and mark the "Canonical Partners" .

Then give in terminal

~$ sudo apt-get update
~$ sudo apt-get install skype

This similar answer as @Subin Huttons gave , but I want to confirm that new Skype 4.1 is not integrated correctly in up bar. I tested too.

Thanks

Brian Marine (crysisfreak7) said : #5

Thanks Subin Hutton, that solved my question.

Gabriel_P (gabp) said : #6

I'm having the same issue. I tried NikTh's solution but after marking the "Canonical Partners" and doing an update I get:

W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ precise/partner amd64 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_binary-amd64_Packages)
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ precise/partner i386 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_precise_partner_binary-i386_Packages)

If I try to install from the Software Center it keeps showing version 4.1.0.20.

Gabriel_P (gabp) said : #7

Found the answer here:

http://ubuntuforums.org/showthread.php?t=1861843

For some reason (Unity, sigh...) Skype needs to be added to the whitelist.

Can you give the output of:

grep -R partner /etc/apt/*

Thanks

N1ck 7h0m4d4k15 (nicktux) said : #9

Skype version updated. Now is 4.1 . I received the update too.

For the duplicate sources , follow @andrew and give the results :-)

Thanks

Gabriel_P (gabp) said : #10

This is the output of 'grep -R partner /etc/apt/*':

/etc/apt/sources.list:## 'partner' repository.
/etc/apt/sources.list:deb http://archive.canonical.com/ubuntu precise partner
/etc/apt/sources.list:# deb-src http://archive.canonical.com/ubuntu precise partner
/etc/apt/sources.list.d/precise-partner.list:deb http://archive.canonical.com/ubuntu precise partner #Added by software-center
/etc/apt/sources.list.d/precise-partner.list.save:deb http://archive.canonical.com/ubuntu precise partner #Added by software-center
/etc/apt/sources.list.save:## 'partner' repository.
/etc/apt/sources.list.save:# deb http://archive.canonical.com/ubuntu precise partner
/etc/apt/sources.list.save:# deb-src http://archive.canonical.com/ubuntu precise partner
grep: /etc/apt/trustdb.gpg: Permiso denegado

sudo rm /etc/apt/sources.list.d/precise-partner.list.save
sudo rm /etc/apt/sources.list.save
sudo rm sudo rm /etc/apt/sources.list.d/precise-partner.list
sudo apt-get update

Gabriel_P (gabp) said : #12

Thank you Andrew , that solved the 'duplicate' issue in my sources.

Cheers.

PD: There's an extra 'sudo rm' in the 4th line.

Sorry, typo. Nice catch