Language is not chosen correctly

Asked by Lars on 2018-07-16

Hi *,

I want to use simple-scan in Ubuntu 18.04 LTS (Bionic Beaver) with Mate Desktop but cannot get the program to launch in German language.
In Mate, the whole GUI is set to German language and I have no issue with any other application (Libreoffice, VLC, Mate itself, ...).
The environment variable LANG="de_DE.UTF-8" is set and even setting LC_ALL to this value does not help.

I wonder how simple-scan reads the system settings and why it seems that it cannot determine the actual setup.
Launching simple-scan with the --debug option does not show me any output concerning the language settings.

There is no difference between launching simple-scan as a user or as root. It always launches with English language.

On another computer I use a similar system (same Ubuntu version, also together with Mate) and there simple-scan correctly launches with German language (as user and as root). I do not see any difference between the two systems and a hint where to look at would be much appreciated :-)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu simple-scan Edit question
Assignee:
No assignee Edit question
Solved by:
Lars
Solved:
2018-07-16
Last query:
2018-07-16
Last reply:
2018-07-16

In a terminal on each system, run:

env

Are there any differences?

Manfred Hampl (m-hampl) said : #2

Do you have the package language-pack-gnome-de-base installed?

Lars (unknown.user) said : #3

The two systems have a complete different use so there are many differences. But I cannot see any config item that might be relevant being different.
The only very important thing I forgot to mention is that on the system I have the issue I am running the user in guest mode.
But as i said, there is no difference in running simple-scan from a root terminal or from a user terminal.

First post here so I do not know how or if I can quote. Pasting the output from diff -y in the hope it's not a complete mess (removed some obviously too irrelevant lines). Left side: Working system, right side problematic one.
P.s.: I also manually added the variable LANGUAGE manually to the right machine temporarily which did not solve the problem either.

             > CLUTTER_IM_MODULE=xim
COLORTERM=truecolor COLORTERM=truecolor
COMPIZ_CONFIG_PROFILE=mate | DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/999/bus,guid=c61
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus | DBUS_STARTER_ADDRESS=unix:path=/run/user/999/bus,guid=c61edfc
             > DBUS_STARTER_BUS_TYPE=session
DESKTOP_SESSION=mate DESKTOP_SESSION=mate
             > DIALOG_SLEEP=4
DISPLAY=:0 DISPLAY=:0
EDITOR=vim <
GDM_LANG=de_DE <
GDMSESSION=mate GDMSESSION=mate
GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1 | GPG_AGENT_INFO=/run/user/999/gnupg/S.gpg-agent:0:1
GSETTINGS_SCHEMA_DIR=/home/gutz/data | GTK_IM_MODULE=ibus
GTK_MODULES=appmenu-gtk-module:gail:atk-bridge:canberra-gtk-m | GTK_MODULES=gail:atk-bridge:canberra-gtk-module
GTK_OVERLAY_SCROLLING=0 GTK_OVERLAY_SCROLLING=0
HOME=/home/user | HOME=/tmp/guest-lgcgxc
LANG=de_DE.UTF-8 LANG=de_DE.UTF-8
LANGUAGE=de_DE <
LESSCLOSE=/usr/bin/lesspipe %s %s | MANAGERPID=1270
LESSOPEN=| /usr/bin/lesspipe %s <
MATE_DESKTOP_SESSION_ID=this-is-deprecated MATE_DESKTOP_SESSION_ID=this-is-deprecated
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin: PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:
             > QT4_IM_MODULE=xim
QT_ACCESSIBILITY=1 QT_ACCESSIBILITY=1
QT_AUTO_SCREEN_SCALE_FACTOR=0 QT_AUTO_SCREEN_SCALE_FACTOR=0
             > QT_IM_MODULE=ibus
QT_QPA_PLATFORMTHEME=gtk2 QT_QPA_PLATFORMTHEME=gtk2
QT_SCALE_FACTOR=1 QT_SCALE_FACTOR=1
SHELL=/bin/bash SHELL=/bin/bash
SHLVL=1 SHLVL=1
TERM=xterm TERM=xterm
UBUNTU_MENUPROXY=1 | TEXTDOMAINDIR=/usr/share/locale/
USER=user | TEXTDOMAIN=im-config
             > USER=guest-lgcgxc
_=/usr/bin/env _=/usr/bin/env
VTE_VERSION=5202 VTE_VERSION=5202
WINDOWID=46137350 | WINDOWID=41943047
XAUTHORITY=/home/gutz/.Xauthority | XAUTHORITY=/tmp/guest-lgcgxc/.Xauthority
XDG_CONFIG_DIRS=/etc/xdg/xdg-mate:/etc/xdg XDG_CONFIG_DIRS=/etc/xdg/xdg-mate:/etc/xdg
XDG_CURRENT_DESKTOP=MATE XDG_CURRENT_DESKTOP=MATE
XDG_DATA_DIRS=/usr/share/mate:/usr/local/share:/usr/share:/va | XDG_DATA_DIRS=/usr/share/mate:/usr/share/mate:/usr/local/shar
XDG_GREETER_DATA_DIR=/var/lib/lightdm-data/user | XDG_GREETER_DATA_DIR=/var/lib/lightdm-data/guest-lgcgxc
XDG_RUNTIME_DIR=/run/user/1000 | XDG_RUNTIME_DIR=/run/user/999
XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0 XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
XDG_SEAT=seat0 XDG_SEAT=seat0
XDG_SESSION_DESKTOP=mate XDG_SESSION_DESKTOP=mate
XDG_SESSION_ID=c2 XDG_SESSION_ID=c2
XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0 XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
XDG_SESSION_TYPE=x11 XDG_SESSION_TYPE=x11
XDG_VTNR=7 XDG_VTNR=7
             > XMODIFIERS=@im=ibus

Lars (unknown.user) said : #4

Obviously, pasting the differences in -y mode without quoting didn't work as expected (Sorry!)

So the only relevant line would be
LANGUAGE=de_DE which I already mentioned (added it to the "faulty" system manually without any change).

Lars (unknown.user) said : #5

That's it! Manfred's suggestion was perfect!
The package language-pack-gnome-de-base was missing on the system and installed on the working one.

After installing it, simple-scan launches in German language. Problem solved. Thanks alot!

(I wonder why the package is needed as the translation comes with simple-scan and the program should rely on the system settings and not on some additional gnome packages... Will have a look into language-pack-gnome-de-base to figure that out...)