My Epson Stylus TX610 is not being detected by Ubuntu 12.04

Asked by Dean van der Merwe on 2012-08-01

I have recently installed Ubuntu 12.04 as a replacement to Windows XP. The transition has been seamless but for the use of my scanner. I have the Epson Stylus Office TX 610 FW. I have checked the Epson site and it seems there are no Linnux drivers for my printer which is a little confusing as my printer works fine. I would very much appreciate it if someone had a quick fix for this problem.

Many thanks to Any and All who contribute

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu simple-scan Edit question
Assignee:
No assignee Edit question
Last query:
2012-08-02
Last reply:
2013-07-23

What apps have you tried to scan with?

Dean van der Merwe (deanv003) said : #2

Hi, Thanks for taking an interest in my query. I have tried the app which was supplied with the download, Simple Scan.

Try xsane

Dean van der Merwe (deanv003) said : #4

Thanks, I tried that but I get the same result, "No Device Recognised". Any other ideas?

ahambidge (ahambidge) said : #5

Hello,

For the scanner to be recognized it has to have a ?????.usb file in the SANE directory gt68xx. Under Linux your scanner may be recognized under another name (Compatible). My Packard Bell scanner is recognized as a Mustek Bearpaw and works great

Search the web for your machine's Linux USB driver. The file has to be copied to the gt68xx directory using the Terminal.

You can also search on this Ubuntu Launchpad Answers.

Regards,

Allan :)

Oliver Story (oliver-story) said : #6

I have the TX610FW connected via the network. On Ubuntu 13.04 both the printer and scanner are recognised out of the box, however I have previously used Epson's drivers as listed below.

Epson also provides drivers for the scanner and printer from their download centre.
1. Visit http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX
2. search for "tx610fw".

The various scanner and printer drivers should be listed.

3. For a USB-connected device, you download and install the "core package & data package". For a network-connected device, you will also need to install the "network plugin package".

Can you help with this problem?

Provide an answer of your own, or ask Dean van der Merwe for more information if necessary.

To post a message you must log in.