Canon pixma mp280 scanner not recognised

Asked by sandra.bodkin on 2012-02-28

February 28

Hi!
I installed my printer to ubuntu 10.10 and have had no problems getting it to work.
I downloaded and installed the drivers for this printer (Canon Pixma mp-280).
The printer was recognised and is working.
The problem is with the scanner. I installed the downloaded drivers as required
and I also installed xsane and updated everything.
Then I turned off my computer and restarted.
When I tried to scan using xsane, it tells me there are no devices available.
What could be the problem?
Any help would be appreciated.
Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu simple-scan Edit question
Assignee:
No assignee Edit question
Solved by:
sandra.bodkin
Solved:
2012-03-08
Last query:
2012-03-08
Last reply:
2012-02-29

If you run:

xsane

from the terminal, attempt to scan. What is output in the terminal?

Thanks

sandra.bodkin (lotus1s) said : #2

Sorry I have been late in getting back to this question. Thanks for taking the time to help.
The output from the terminal was: no media found.
However, I read another question of a similar nature and found the answer in that one.
The solution was to create a desktop launcher for the scanner and it works with the launcher but still won't work with
xsane.
The scanner is recognised in gimp, no problem and will scan from within gimp.
So, if I want to use the scanner, I simply click on the launcher and it opens the scanner.
But it won't work with simple scan or xsane.
So, I don't know if you can consider this problem answered or not, since the only solution seems to be to create a launcher.
If you have a better solution, I would be only too happy to hear it.
Thanks for your help.