Ubuntu

Epson 3170 drivers

Asked by Zach Grogg on 2012-01-21

When I start up Simple Scan I get the message:

No scanners detected
Please check your scanner is connected and powered on

I am using Ubuntu 10.04 on my new computer. When I connected my Epson Perfection 3170 Photo scanner to the USB port both the scanner and Ubuntu acted like nothing had happened. I tried several more times and on different ports thinking that it could be a bad connection. I am in the Device Manager and the computer shows the Epson 3170, but it seems to refuse to connect to it. My dad connected an almost identical model Epson a month back to his Ubuntu machine and it started right up. I have read some of the answered questions about Epson scanners here and none of them seem to be working for me.

Any help would be greatly appreciated!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu simple-scan Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-01-22
Last query:
2012-01-22
Last reply:
2012-01-21

How did you instal the drivers (if at all)?

Can you give the output of:

lsusb; echo; lsb_release -a; uname -a

Thanks

Zach Grogg (yearomonkey) said : #2

I tried to install the packages from http://download.ebz.epson.net/dsc/search/01/search/searchModule.

rufus@Rufus:~$ lsusb; echo; lsb_release -a; uname -a
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 046d:c517 Logitech, Inc. LX710 Cordless Desktop Laser
Bus 004 Device 002: ID 03f0:0d17 Hewlett-Packard LaserJet 1012
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 018: ID 04b8:0116 Seiko Epson Corp. Perfection 3170 (GT-9400)
Bus 003 Device 017: ID 14cd:125c Super Top
Bus 003 Device 015: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.3 LTS
Release: 10.04
Codename: lucid
Linux Rufus 2.6.32-37-generic #81-Ubuntu SMP Fri Dec 2 20:32:42 UTC 2011 x86_64 GNU/Linux

http://askubuntu.com/questions/49389/running-a-epson-scanner-perfection-3170

may help, you may have an older version of cups etc which may be affecting things

Zach Grogg (yearomonkey) said : #4

check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

rufus@Rufus:~$ sane-find-scanner

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04b8, product=0x0116) at libusb:003:018
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.

rufus@Rufus:~$ sudo gedit /etc/sane.d/dll.conf

#epson
epson2

I can make it down tothe part where I:

cd ~/Desktop
sudo alien -d iscan-2.10.0-1.c2.i386.rpm
sudo dpkg -i iscan-plugin-gt-9400-1.0.0-1.c2.i386.deb

Here is the readout.

rufus@Rufus:~/Desktop$ sudo apt-get install alien
Reading package lists... Done
Building dependency tree
Reading state information... Done
alien is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
rufus@Rufus:~/Desktop$ cd ~/Desktop
rufus@Rufus:~/Desktop$ sudo alien -d iscan-2.10.0-1.c2.i386.rpm
error: incorrect format: unknown tag
Warning: Skipping conversion of scripts in package iscan: postinst postrm preinst prerm
Warning: Use the --scripts parameter to include the scripts.
mkdir: cannot create directory `iscan-2.10.0': File exists
unable to mkdir iscan-2.10.0: at /usr/share/perl5/Alien/Package.pm line 257.
rufus@Rufus:~/Desktop$ sudo dpkg -i iscan-plugin-gt-9400-1.0.0-1.c2.i386.deb

Could this be part of my attempts from earlier to install the updates?

Zach Grogg (yearomonkey) said : #5

Alright, I followed everything on the page. Simple Scan has "Epson" as the scan source and is ready to go, but when I want it to scan it comes up with:

Failed to scan
Unable to start scan

Whan I start it up in GIMP and go to File/Create/Xsane/Device Dialogue it comes up with 4 xsane windows. When I tell it to print from here, an error message appears stating "Failed to start scanner: Invalid argument."

I'm getting the same results as this.
http://ubuntuforums.org/showthread.php?t=1028064&page=2

Zach Grogg (yearomonkey) said : #6

Thanks for your help again actionparsnip. I managed to get Virtualbox to detect it and I installed the scanner in my Windows XP. Not ideal, but it works.

Zach Grogg (yearomonkey) said : #7

Thanks actionparsnip, that solved my question.