Simple Lightdm Manager Ubuntu 12.04 does not work

Asked by BuelentR on 2012-04-25

I cannot change the Login Screen with Simple Lightdm Manager in Ubuntu 12.04: I change tthe backgriund image, Apply changes, but background image stays the one provided by Ubuntu.

Question information

English Edit question
Ubuntu simple-lightdm-manager Edit question
No assignee Edit question
Last query:
Last reply:

Install ubuntu-tweak and you can change it there.

BuelentR (amodent) said : #2

Dear Actionpaesnap,

this does not answer my question, since the new version of Ubuntu-Tweak exactly dropped the feature for changing the login-screen in its new version 0.7


> To: <email address hidden>
> From: <email address hidden>
> Subject: Re: [Question #194703]: Simple Lightdm Manager Ubuntu 12.04 does not work
> Date: Wed, 25 Apr 2012 16:41:11 +0000
> Your question #194703 on simple-lightdm-manager in Ubuntu changed:
> Status: Open => Answered
> actionparsnip proposed the following answer:
> Install ubuntu-tweak and you can change it there.
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> You received this question notification because you asked the question.

Ubuntu-tweak is a 3rd party app. I suggest you contact the ubuntu-tweak team

BuelentR (amodent) said : #4

Thank you. But my original problem was not with Ubuntu Tweak - you brought it up as a possible solution (and regarding the dropped possibility of changing the Login Screen I am actually in contact with the Ubuntu Tweak Team.)

My question or remark was that I cannot change the Login Screen with "Simple LightDM Manager" in Ubuntu 12.04. I installed the programme, select a background image, klick "Apply Changes", the programme says that I was successful, a small thumbnail is shown, but when I restart the computer the usual Ubuntu Login Screen appears. Changing the Unity-Greeter.conf file also does not help...


Alex (myersg-5) said : #5

I am having the same problem, I change my back ground, log out and its still the ubuntu default on the login screen...

Leon Alvarez (locoxella) said : #6

Glad to see im not alone. Had anyone tried to completly remove lightdm and reinstall? Does this happens to anyone when doing a fresh install or just when upgrading, like happened to me?

Could install gdm instead...

Kenny3794 (kenny3794) said : #8

Alex and Andres,

I'm having the same issue. I tried the following:

   >> sudo dpkg-reconfigure lightdm

...but this did not change anything. anyone else have an idea?


Leon Alvarez (locoxella) said : #9

For me, it wasn't working because my home folder is encripted, and of course, unity-greeter does not have the rights to see my customized wallpaper (only the default wallpapers of Ubuntu, outside my personal folder). So I simply put my wallpaper in /home directory and did a chmod 444 to the file, just in case. And now its working. It will be really cool if copy of the wallpaper with the right permissions for unity-greeter to use it were made every time we change it. Perhaps this bug its the expected behavior of Ubuntu? To protect our encipted home folder?

Bob Richard (robertrichard) said : #10

I have been running 12.04 for a weeek or so with no problem. Last night, the system started acting up and I rebooted. The system wnt to an 'orange' login screen and would not log in. I used Cntl + Alt + f1, got to 'tty' screen and logged in from there. started 'lightdm', and it took me back to hte same 'orange' login screen. No option worked other than above worked.

I can't figure out how to get a log to send out to determine the problem. I don't know if this is the right venue, but it's the closest I could find.

I'm using a 'Windows 7' machine to sned this.

Thank you.

I'm having an issue with the login-form being left of visibility on the login-screen:

To make matter worse, I can't find/launch Simple Lightdm Manager. I see that I have these packages installed: lightdm and liblightdm-gobject-1-0. How do you launch the gui?

This thread sheads some light, but not much help:

Alright guys, there's no utility for this, open a root terminal,

sudo gedit

Open - /etc/lightdm/unity-greeter.conf

See the line that says Background? Change that to your image. You may have to edit the image to fit the dimensions you want.

Now this question can be marked solved.

Oh and, I figured this would be obvious, but save it and restart your session/machine to make sure it takes effect. Also, backup stuff before you touch it, backups are good...

gksudo gedit


sudo gedit

Show me a difference? It gets the job done either way. Besides, the solution works.

sudo doesn't setup the X environment correctly as it is for terminal based apps only. gksudo (and kdesu for KDE) setup the graphical environemt correctly by incorporating display variable and GTK libs. If you use sudo with GUI apps, you can and will make your ~/.ICEAuthority file owned by root, you will then not be able to use sudo to change the ownership back and need to boot to root recovery mode to change it back to your user. This can all be easily avoided if you just use the correct method in the first place.

Also see:

That is the brain of the bot from the official support channel #ubuntu on

Here is a real user showing just what it can do:

Again. GKSUDO for GUI apps. If you want to mess up YOUR system, that is fine but when advising users, use the proper way please, that way other users don't have to clear up your mess when you screw up their files. Its simple to avoid too.

Any other questions, just let me know and I'll fill you in

But if the file is already locked due to it being in the system directory, what's wrong with using sudo? I've actually never had problems with running gedit with sudo. However, I can understand running it as root to edit something in home would cause problems, but I've never actually tried it. Whatever man, you have your answer, just edit the configuration file manually in whatever method you choose, with whatever method of privilege escalation you prefer.


^ Note at bottom, I see what you mean.

Didn't realize providing a solution would cause so much negative feedback. 'Preciate your time.

mikewhatever (mikewhatever) said : #19

There is no /etc/lightdm/unity-greeter.conf in Precise 12.04.1, all I have is this:

~$ ls /etc/lightdm/
lightdm.conf users.conf

I've researched a few alternatives to the missing configuration file.

A little bit about dconf in tandem with that answer \/


There are some mentions of gsettings in these posts and some information about the methods of using gsettings to change this wallpaper.

This previous link does not guarantee a fix, but may lead you down a path to a method that works for you.

Hope this helps.

Instalar o Ubuntu 12.04 PP LTS ou superior-tweak e você pode alterá-lo lá.

Instalar o Ubuntu 12.04 PP LTS ou superior-tweak e você pode alterá-lo lá.

Instalar o Ubuntu 12.04 PP LTS ou superior-tweak e você pode alterá-lo lá, veja a IMAGEM nesse link:

Can you help with this problem?

Provide an answer of your own, or ask BuelentR for more information if necessary.

To post a message you must log in.