After installing Webapps, I get "not all updates can be installed" message with "partial upgrade" option. signond is unable to update.

Asked by John Janney on 2012-07-27

I'm running Ubuntu 12.04 on a Gateway laptop. I keep everything up-to-date via the Update Manager.

I installed Webapps using the instructions on OMG Ubuntu.

Now I'm getting "Not all updates can be installed" messages from the Update Manager, and I'm getting an option to run a "Partial Upgrade" (which kinda makes me a bit nervous). In the Update Manager, one update from the webapps PPA is "grayed-out" and not able to be checked. This uncheckable update is signond (Single Sign On framework).

Should I run the partial upgrade? I've read horror stories on OMG Ubuntu about Webapps breaking the system, so I'm very nervous about doing this. Is there some other solution?

In other words: What should I do?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu signon Edit question
Assignee:
No assignee Edit question
Solved by:
John Janney
Solved:
2012-07-27
Last query:
2012-07-27
Last reply:
John Janney (johnjanney) said : #1

I ran

     $sudo apt-get update

and then

     $sudo apt-get install signond

and that seemed to fix the issue.