Shutter not working in Cairo-dock

Asked by Eglefino on 2015-03-08

I don't know if it's a bug (because I don't have an error message), so I try to ask a message at first here.

It's pretty pretty difficult to tell with what I'm working now, but installed Ubuntu 14.04 desktop/amd64, after that installed in the software centre Gnome Flashback (& Shutter) than Cairo-Dock + plugins. In the dconf-editor Shutter isn't written, but in Synaptic & SoftwareCentre it's installed on my computer. In the program menu it's written by the help-tools (the 1st) and I clicked it maybe four times but nothing, even after a reboot and a re-install of Shutter in Synaptic.

Cairo-dock was installed with the mediaplayer 'Exaile' that's too not working, but has nothing to do with this answer (I think). I have watched/searched for bugs in Shutter/Ubuntu and Cairo-Dock/Shutter and on both websites, so more as that I don't know.

I'm working on a Quad Core i7-920 with 12GB Ram. Shutter is working with Gnome Flashback (metacity), I've not tried in compiz....

There is now other program as Shutter in Ubuntu, otherwise I tried another one.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shutter Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2015-03-17
Last query:
2015-03-17
Last reply:
2015-03-09

Try launching it from a terminal, the output may help

Eglefino (ruudino-k) said : #2

Sorry my reaction is so late, I can't nothing from it, because my health/condition.

I tried your solution and got this:

eglefino@Eglefino-PC:~$ shutter
defined(@array) is deprecated at /usr/bin/shutter line 3736.
 (Maybe you should just omit the defined()?)
defined(@array) is deprecated at /usr/bin/shutter line 3747.
 (Maybe you should just omit the defined()?)
WARNING: gnome-web-photo is missing --> screenshots of websites will be disabled!

WARNING: Net::DBus::GLib is missing --> Ubuntu One support will be disabled!

WARNING: Image::ExifTool is missing --> writing Exif information will be disabled!

INFO: There is already another instance of Shutter running!

The next day I found out, I had an update of Cairo (after a electric/power failure) and when started there was a icon of shutter on my dock and it's working.....

So what the solution is I don't know.... it's working :-).

Thanks for your help.

Eglefino (ruudino-k) said : #3

I would this set on [SOLVED] but the program (here) don't let me do it, see "The question is not in a state where you can confirm an answer."

Today I will try it again....Launchpad is for some Ubuntu-members a real f*ck... pffff

Eglefino (ruudino-k) said : #4

By the way I stopped with Cairo, too many program & a not working screen changer for the .... don't know the name in English... in Dutch it's named: "Werkblad Wisselaar"

And again I get no button to SOLVED this correspondence, maybe I unsubscribe from this item pffff