How to disable the link MissingFile on Shotwell

Asked by neeraj001 on 2012-09-17

       I have some personal photos which are encrypted by CryptKeeper. I doesn't like to disclose them to anyone. Whenever i lke to view them, I mount them using CryptKeeper. I need to include these photos in Shotwell photo manager at the time of mounting. So, I mounted them using CryptKeeper. Then I imported them to Shotwell. I made a new event and etc to organize and view those photos. After that I unmounted them using CryptKeeper because someone may see it. Now I don't want any single trail on Shotwell beacuse of the same problem. But there is a new button 'MissingFiles' appeared and when i clicked on it, all the photo thumbnail which i unmounted showed there. I dont't want right'click on them and select 'remove from library'; beacuse when i want to view them next time on Shotwell, I need to import, organize, etc at that time. So, the only option here is to disable the unavailability of that MisssingFiles button.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu shotwell Edit question
Assignee:
No assignee Edit question
Last query:
2012-09-17
Last reply:
2012-09-17

You could use another app for the encrypted files (like f-spot) and use shotwell for the rest

Adam Dingle (adam-yorba) said : #2

Another solution is to have two different Shotwell libraries: one for your private photos and one for the not-so-private ones. When you run Shotwell you can use the -d option to specify a data directory where Shotwell will keep its database and thumbnail files. It would be nice if the default import directory could be different for each library, but Shotwell doesn't support that yet (see http://redmine.yorba.org/issues/2146). So this solution will work today only if you import photos into each library in place, i.e. without copying to the default directory.

Can you help with this problem?

Provide an answer of your own, or ask neeraj001 for more information if necessary.

To post a message you must log in.