e-mailing photos from shotwell not working

Asked by John Wilson on 2011-12-16

When I try to prepare a photo for e-mailing in shotwell I select the photo and then right click on it.
The Send to dialogue box opens but when I click OK the process dies.
Is this a bug or am I doing something wrong?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shotwell Edit question
Assignee:
No assignee Edit question
Solved by:
John Wilson
Solved:
2011-12-19
Last query:
2011-12-19
Last reply:
2011-12-17
Chris (fabricator4) said : #1

What release of Ubuntu are you running? There _was_ a Nautilus send-to bug that affected Shotwell, but it should have been fixed.

Chris

John Wilson (jwilsondmartin) said : #2

Chris
Thank you for your reply.
I am using 11.10

Chris (fabricator4) said : #3

The original bug I saw was in 11.04, and strictly speaking it was a Nautilus bug. It seems there is still a problem however, and you should file a launchpad bug for it.

Chris

Adam Dingle (adam-yorba) said : #4

John,

which process dies? Shotwell? If Shotwell is crashing, could you try to reproduce this running Shotwell from the command line like this?

$ shotwell

When Shotwell crashes, do you see any output on the console?

John Wilson (jwilsondmartin) said : #5

Hi Adam,
Thank you for your interest.
Shotwell does not crash totally. Only the bit bit where I am wanting to e-mail a picture.
There does seem to be a problem when I run Shotwell from a terminal.
Here is the output:
shotwell

(shotwell:5126): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(shotwell:5126): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(shotwell:5126): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(shotwell:5126): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
Regards,
John

Adam Dingle (adam-yorba) said : #6

John,

I think those warnings are probably benign and unrelated to the problem you're seeing.

What evidence do you have that any process is crashing? I don't understand what you mean by "Shotwell does not crash totally". Either the process has crashed, or it hasn't - there's no possibility in between. :)

Is it possible that you're seeing the following bug, which was present in Shotwell 0.11 (and has been fixed for 0.12)?

http://redmine.yorba.org/issues/4432

Because of that bug, when you try to send photos in Shotwell 0.11 sometimes the Send To dialog simply fails to appear. (There is no process crash, however.)

John Wilson (jwilsondmartin) said : #7

Adam
Thank you for your quick reply.
I think I am seeing this bug.
The photos I have been trying to e-mail have not been edited.
Thank you for fixing it and I will try and download Shotwell 0.12
Regards,
John

Adam Dingle (adam-yorba) said : #8

OK, great. Be aware that Shotwell 0.12 doesn't exist yet: it's in development, and will be released in February 2012. If you want, you can build the latest Shotwell sources from git master, which include the fix for the bug above:

http://yorba.org/shotwell/install/

The development build may not always be completely stable, but we appreciate any testing efforts and welcome feedback.

John Wilson (jwilsondmartin) said : #9

Added Yorba's PPA to my repository.
It would seem I am running Shotwell 0.11.6 so I will just have to wait until 0.12 comes out
Thanks for your help
John