shotwell

Asked by Dan Blum on 2011-11-28

I am running Ubuntu 10.latest. My hardware was not current enough to update to version 11.

When running Shotwell (9.3), it will not import some photos from a local directory, not sure what the issue is. I thought that if I update shotwell to the newest version (11.6) the problem would go away. So, when I downloaded the latest version of shotwell, among other things it asked for gtk+3.2. My system will not update past 3.0 from the repository. If I compile gtk+3.2 from scratch, will that work, or will I be running around in circles?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shotwell Edit question
Assignee:
No assignee Edit question
Solved by:
Dan Blum
Solved:
2011-11-29
Last query:
2011-11-29
Last reply:
2011-11-29

Are you adding a PPA to get the newer version?

If you are using Maverick then you will not have Gnome3 which the newer version will probably need.

Dan Blum (dan-blm) said : #2

Thanks for the reply. Maverick is not a listed software for Ubuntu and I am not using it, and I am not adding a PPA. Why will shotwell not see the content of the directory, when a regular window does? Seems like I am on my own.

Can you give the output of:

lsb_release -a; apt-cache policy shotwell

Thanks

Dan Blum (dan-blm) said : #4

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
shotwell:
  Installed: 0.9.3-0ubuntu0.1
  Candidate: 0.9.3-0ubuntu0.1
  Version table:
 *** 0.9.3-0ubuntu0.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     0.9.2-0ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

try:

sudo add-apt-repository ppa:ematux/natty-extra; sudo apt-get update; sudo apt-get upgrade

Should help

Dan Blum (dan-blm) said : #6

The command above updated shotwell to 11.2; still the same problem. I can read the files with gimp and the gnome, so I am not sure if anything else needs to be done. The yorba.org site does not have a spot to report bugs.

Adam Dingle (adam-yorba) said : #8

Yorba does has a place to report bugs. As mentioned on the main Shotwell page (http://yorba.org/shotwell/), our bug tracker is at http://redmine.yorba.org/projects/shotwell/issues .

Adam Dingle (adam-yorba) said : #9

1. What happens when you try to import these photos into Shotwell? Do you see an error message, or are they simply ignored?

2. From the command line, try running Shotwell directly on one of these photos:

$ shotwell /path/to/photo

What happens? Do you see an error message?

3. Try running Shotwell with an empty library for testing:

$ shotwell -d foo

Now try to import the photos. Will they import?

Dan Blum (dan-blm) said : #10

For the import, a window was opening with all the lines grayed out, like it was not reading the folder correctly, and could not select anything. I have not seen a window like that before. It seemed that it was not reading the files correctly.

I just now clicked OK and a dialog popped up: copy in place, copy and cancel. I selected copy and all the photos loaded. When I tried to redo the same operation to see the (popup) window, and pressed cancel, I could not exit from the window (it locked up). I killed it from the console.

So it is working, but there are issues: the lines should not be grayed out in the window, and cannot select individual files. Thanks for the help.