What does Shotwell mean by an 'event'?

Asked by Alan Braddock on 2011-07-25

I imported 9,000 JPEG files withe various dates. Many have been listed as having 'no event'. What is this supposed to mean?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu shotwell Edit question
Assignee:
No assignee Edit question
Last query:
2011-07-25
Last reply:
2012-08-16
Alan Braddock (braddem) said : #2

Apparently an event is a date. I thought that that was the case. Why doesn't Shotwell always take notice of the date then? Even if I alter or insert the date of one of these 'no event' photo's, it is still included in the 'no event' list.

Jim Nelson (yorba-jim) said : #3

Shotwell only automatically assigns a photo to an event based on its exposure date at import time. After that, Shotwell will not move a photo into or out of an event if you alter its date/time; you must manually assign photos to events after that.

For the photos in "No Event", you can select them and drag them to an existing event. Or, choose Events -> New Event to create a new one.

Some times people think Shotwell's Events are a purely chronological sorting of their photos. It doesn't quite work like that. We do have a ticket for sorting photos purely on their exposure date time: http://redmine.yorba.org/issues/2747

RayArdia (theallinsons) said : #4

Shotwell on Oneiric
Generally speaking I am pleased that Shotwell has been chosen as the 'in-house' photo manager for Oneiric. I like almost all of its features and it updates automatically too, to latest (hopefully stable!) version.

One area in which I am having real trouble is that when I import a scanned image it dives straight into the 'NO Event' area even when I have taken tortuous steps to add an Original Date, even though usually only Year and Month are correct.
Can we please have a way of 're-filing' these No Event images and other images found to be 'mal-filed' to their correct Year/Month/Date slots?

After reading Jim Nelson's comments I tried the 'New Event' route, chose a scanned image without exif data (except for it's scanned date) and first tried to drag it to the year 'event' where I knew it should be. Drag 'n Drop didn't work. Tried to make a new event - failed as both 'New Event' and 'View event for Photo' were greyed out. Somehow, later, I managed to make a new event, which showed as 'New Event 380' just above the 'No Event' entry. This new entry seems to have no function at all.

On another issue, I searched for similar issues on the yorba site, and found quite a few listing similar problems to mine, ie regarding the re-assignment of No Event images. In each case they were shown as solved, completed or similar but with nos solution shown nor a work-around given.
incidentally, do others find the Yorba system for recording bugs - and their mailing lists just a TINY bit con.fusing? I know that I do!

__________________

Adam Dingle (adam-yorba) said : #5

Ray,

what tortuous steps are you taking, exactly, to add an original date to your scanned images? Shotwell should recognize a date in any of several EXIF tags (Exif.Photo.DateTimeOriginal, Exif.Photo.DateTimeDigitized, Exif.Image.DateTime). Could you attach a photo which you have added a date to, but which Shotwell nevertheless places in No Event?

When you say you "tried to drag it to the year 'event' where I knew it should be", were you dragging a photo onto a year in the Shotwell sidebar? That won't work: a year is not an event in Shotwell, and you can only drag into events. As described in the Shotwell help at http://yorba.org/shotwell/help/event.html , to create a new event you must first select one or more photos to be in the new event, and then run the New Event command. So if 'New Event' is grayed out then you probably haven't selected any photos yet. When you say "This new entry seems to have no function at all", what do you mean? Are you unable to drag photos to it?

What do you find confusing about Yorba's bug tracker and mailing lists? What could we improve or change to help you understand these or make them easier to use?

Graham White (graham-dcs) said : #6

I am in a situation where I have forgotten to set the camera's date and time, so the date and time end up with the default date/time. If you import like that, then you can sometimes adjust the date and time of photographs from their place in the last import folder, but sometimes not: Shotwell seems to be OK for a while, but after that all of the menu entries, both for "photos" and for "events", seem to be permanently greyed out, the photos that you want to adjust are in "no event", and nothing that you try to do will help. I have thought that maybe this is to do with the Shotwell DB getting into an inconsistent state, but I have checked photos.db (using sqlite3) and it seems to be OK. So I'm at a loss.

I am also, to he honest, very unclear about what Shotwell means by an "event". If it's a date, then call it a date: if it is possible for it to be not a date (maybe something which stretches over a long time range with interruptions) then it's not a date, but an event (maybe) or a process. Shotwell seems to fall between the two, allowing you to create more complex events once you've imported photos, but always assigning events on import. It would also be useful to be able to move photos to the "No Event" folder (maybe you have realised they are in the wrong event, but don't want to make your mind up just yet). But I find it all rather confusing, and I'm using Shotwell almost exclusively as a photo organiser.

Adam Dingle (adam-yorba) said : #7

Graham,

if the camera doesn't give a photo a date and time then yes, the photo will end up in No Event. You can then set the photo's date and time and, unfortunately, it will remain in No Event. We consider that a bug, and in fact we're about to fix that for the upcoming 0.13 release. See http://redmine.yorba.org/issues/1940 . In the meantime, in this situation you'll need to drag the photo into an existing event and/or create a new event for it.

The entries in the Photos and Events menus are normally all grayed out when you haven't selected any photos. If any photos are selected, then at least some of the items in these menus should be available. Are you not seeing that?

Events in Shotwell are intended to hold groups of photos which were taken at nearly the same time. By default, each event holds photos from one single day, and if you're OK with that then you can just leave events as they are. If you want, you can combine the photos from several adjacent days into a single event, or break a single day's photos into two separate events, for instance. It's possible to create events with photos from very different dates, but that's not what events are intended for and we discourage that.

It's true that you can move photos out of No Event but not into No Event, which does seem inconsistent. We might try to improve that; see http://redmine.yorba.org/issues/2665 .

On the other hand, lots of users find events confusing (as you have), and I'm pretty tempted to replace them with a fixed date-based hierarchy in some future version of Shotwell.

Can you help with this problem?

Provide an answer of your own, or ask Alan Braddock for more information if necessary.

To post a message you must log in.