Copy to library doesn't work--always imports "in place" no matter what

Asked by Jason on 2011-06-08

The first time I imported from my camera, Shotwell copied the photos to my Pictures folder using the Year/Month/Day directory structure. I thought this was excellent. However, when I try to import photos from a folder, it doesn't exhibit the same behavior. Although I was prompted to either "Copy" or "Import in place", it seems that it *always* does the latter even when I choose Copy. How can I get it to copy my files to the Year/Month/Day structure when importing from a folder? Thank you, in advance!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shotwell Edit question
Assignee:
No assignee Edit question
Solved by:
Eric Gregory
Solved:
2011-06-09
Last query:
2011-06-09
Last reply:
2011-06-08
Eric Gregory (eric-yorba) said : #1

Are you importing photos that are already in your Pictures folder, or are they in another folder?

Jason (jason-68000) said : #2

Thanks for the reply. I have tried it both ways. On my first attempt, the folder from which I was importing was indeed in the Pictures folder. During that attempt, I don't believe that I was even prompted whether to Copy or import In Place. Suspecting this might have been the problem, I moved the Last Import to the trash and then tried importing again, this time from my Downloads folder. I also tried importing from an external Flash drive. When prompted, I chose to Copy. But, instead, Shotwell imported the pictures In Place. After importing to Shotwell, I selected the option to show the file, and it revealed that Shotwell was pointing to the file on my flash drive. I also browsed to the Pictures folder and confirmed nothing had been copied.

Best Eric Gregory (eric-yorba) said : #3

Shotwell detects if you've already imported the image. It's designed to skip duplicates. If you import something that's in the trash, it simply moves it out of the trash.

The easiest thing to do would be to delete the files from Shotwell (from the trash) and re-import them.

Jason (jason-68000) said : #4

Thank you! That resolved my issue.