Unable to reauthorize Shotwell and Facebook

Asked by Rob on 2011-03-25

I recently changed my facebook password and when I tried to publish some pictures to facebook from shotwell it said my session key had become invalid. I have followed the directions on how to authorize it again but when i try to it won't let me. I would like to know how to fix this, cause use this app a lot for that very purpose.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shotwell Edit question
Assignee:
No assignee Edit question
Solved by:
Eric Gregory
Solved:
2011-03-25
Last query:
2011-03-25
Last reply:
2011-03-25
Best Eric Gregory (eric-yorba) said : #1

Close Shotwell, and open GConf editor.

In Gnome it's under Applications->System tools->Configuration Editor

In GConf editor:
Open apps->Shotwell->Sharing

Click Facebook, then delete the session_key, session_secret, uid, and user_name keys.

Now restart Shotwell and your credentials should be gone.

Eric Gregory (eric-yorba) said : #2

Also, do you know what steps you took that made the session key invalid?

Please let us know if this happens again, if there's a bug here we need to fix it.

Rob (rstreeter78) said : #3

Thanks Eric Gregory, that solved my question.

Rob (rstreeter78) said : #4

All I did was change my Facebook password and that is all it must have took to do that. Thanks again for the help

Eric Gregory (eric-yorba) said : #5

No problem, and thanks for the info -- I was able to replicate the issue. I've filed a bug here:
http://trac.yorba.org/ticket/3412