Publish to an existing album greyed out

Asked by Bill Hammond on 2011-01-11

When uploading photos to my Facebook account, the "publish to an existing album" choice in the publishing dialog is always greyed out, leaving "create new album" the only choice. My Facebook photo page has several existing albums in it.

Bottom line: why is the existing album choice greyed out?

Many thanks for your help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu shotwell Edit question
Assignee:
No assignee Edit question
Solved by:
Adam Dingle
Solved:
2011-01-11
Last query:
2011-01-11
Last reply:
2011-01-11
Best Adam Dingle (adam-yorba) said : #1

See this answer from the Shotwell FAQ (http://trac.yorba.org/wiki/Shotwell/FAQ):

Why can't I publish to one of my existing albums when uploading to Facebook?

This was a problem with the way Shotwell 0.7 requested permissions from Facebook, and has been fixed in Shotwell 0.8.

Note that users experiencing this problem will likely still experience it after upgrading to 0.8. You will have to do one or two additional things to enable the fix to work with your Facebook account. At the very least, you'll have to log out of Facebook in Shotwell and then log back in. Some users may also need to unlink the Shotwell Connect application from their Facebook profile then re-authorize it. If, after logging out and logging back in, you still can't see your existing Facebook albums, do the following:

1. Open your web browser and log into your Facebook account.
2. On the Facebook welcome page, click "Account" in the upper-right-hand corner and then choose "Privacy Settings" from the drop-down menu.
3. Locate the "Applications and Websites" section in the lower-left-hand corner of the page that loads, then click the "Edit your settings" link.
4. Click on "Shotwell Connect" in the "Applications you use" list.
5. On the page that loads, click the "Remove application" link.
6. Launch Shotwell and attempt to publish some photos to Facebook; you will explicitly have to re-authorize the Shotwell Connect application. Re-authorization should cause the fix to take effect.

Bill Hammond (ka1ssr) said : #2

Thanks Adam Dingle, that solved my question.

Bill Hammond (ka1ssr) said : #3

I was running Shotwell 0.7.2, the version that came with Maverick. I downloaded the latest version from Yorba and installed it. Everything's bunnies and cupcakes now!

Thanks for the speedy reply!

Bill